Fifth generation of iPhone. Repair of this device is straightforward, and requires screwdrivers, prying tools, and patience. GSM/CDMA / 16, 32, or 64 GB / Black or White.

2934 Questions View all
Question Closed

Replaced iPhone 4s Display And Battery Now No Service? Help

Hi, I recently attempted to replace the front and back cover to my iPhone 4s, lack of concentration in the beggining lead me to remove the battery without unscrewing/unplugging the connector and tearing the ribbon straight off the battery.

I was fuming but then proceeded with much concentration to change the display, taking care on everything i did and ordered a new battery for the phone.

A few days passed while i was waiting for the delivery so I could not check if the phone worked straight away, after i fitted the battery and after seeing 'searching...' for 5 minutes, it appeared with 'No Service'. Could not call or text from it or recieve either.

I've taken the phone apart 3 or 4 times now trying to work out what i may of done wrong but all i have seemed to do is round the screws after so many failed attempts. (New screws on the way).

There are a couple of times where i have had a signal, mainly either 1 bar or full bars but then i try to ring out and says call failed, then back to 'No Service'.

I have read through pretty much every question and solution on this website and still no joy.

The phone;

Is on UK Network EE

Recognises my SIM card

States the correct time and date

Connects to Wifi

Was on iOS5 when I first had the issue

Has been updated to iOS6

Has been restored to factory settings

Does have a few screws missing due to rounding off the screws (Hopefully new screws arrive soon)

Im unsure what a blue resistor looks like, let alone where to find it so im unsure if that is the issue,

Im really getting annoyed now all this bother just to get a shiny blue screen, somebody PLEEEASE help before I launch it at a brick wall!

Thank you

Dave

Answer this question I have this problem too

Is this a good question?

Score 0
Add a comment

Free Shipping on all orders $79.00 and up.

Browse Our Store
MANTA DRIVER KIT
112 bit driver kit $59.99
MANTA DRIVER KIT
112 bit driver kit $59.99

1 Answer

This may be an un-reparable situation but make sure the slimy black cable going from the bottom dock to the right of the spot where the battery connects. You have to make sure this clicks in perfectly. If you think this may have been damaged then I suggest buying a new dock (Follow the cable to the new part that you need.

I hope this helps.

Was this answer helpful?

Score 0
Add a comment
View Statistics:

Past 24 Hours: 0

Past 7 Days: 0

Past 30 Days: 0

All Time: 1,495