APC Back-UPS RS,600 Watts /1000 VA,Input 120V /Output 120V, Interface Port USB, Rack Height 2.

2 Questions View all

Overload alarm lights and sound

My ups, after 5 years of continuous operation shows the overload's light .

I unplugged the PC and I replaced the battery but I have not solved the problem.

Then I opened it to see if there are components that are burned or leak but nothing.

To be sure I replaced the cooling fan but nothing has changed.

Can anyone give me some tips?

Thank you very much.

Answered! View the answer I have this problem too

Is this a good question?

Score 3

Comments:

Hi, i had the same problem twice...!!!

My battery was ok, everything was ok but

the beep keep going on, for overload...

Both times i fixed doing these steps...

- Turn off the unit

- Flip over the unit

- Open the battery-cap and turn the power on

- Green Light is flashing

- Try Now (with the green light flashing) to disconnect the battery...

- Now it should be ON with the Empty battery light on (Red light)

- Connect again the battery as it is...

Now it should be ok...!!!

Good Luck...

by

Add a comment

4 Answers

Chosen Solution

Thanks to all. I have not solved the problem. I replaced the old ups with a new one.

Was this answer helpful?

Score 0
Add a comment
Most Helpful Answer

Roberto, If it alarms, even with nothing plugged in, then it is possible that one of the MOSFET on your mainboard has failed.

Was this answer helpful?

Score 4

Comments:

metal–oxide–semiconductor field-effect transistor (MOSFET)

http://en.wikipedia.org/wiki/MOSFET

by

Did you solve the problem? Same problem here, 4 years later..

daigoph@gmail.com

by

Add a comment

Hi, i had the same problem twice...!!!

My battery was ok, everything was ok but

the beep keep going on, for overload...

Both times i fixed doing these steps...

- Turn off the unit

- Flip over the unit

- Open the battery-cap and turn the power on

- Green Light is flashing

- Try Now (with the green light flashing) to disconnect the battery...

- Now it should be ON with the Empty battery light on (Red light)

- Connect again the battery as it is...

Now it should be ok...!!!

Good Luck...

Was this answer helpful?

Score 0

Comments:

Thank you but I replaced the old ups with a new one. Yours sincerely.

by

Add a comment

I too facing the same problem....battery charging process is fine...but when i turn on the inverter it trips and shows overload and keep continuosly beep beeps....pls help me to solve this problem....i expecting board level service suggestions ...thank you

Was this answer helpful?

Score 0
Add a comment

Add your answer

Roberto will be eternally grateful.
View Statistics:

Past 24 Hours: 29

Past 7 Days: 187

Past 30 Days: 818

All Time: 7,799