Disk permission errors not resolving

My MBP is giving boot up trouble hence I ran disk utility from Snow Leopard OS DVD and verified disk - no errors. Checked disk permissions and it gave a big list of errors - ran repair disk permissions and it said repaired. But when I ran the permissions verification again and almost all previous errors showed up once again. This means the "repair" was not done. what could be the problem? Is my OS DVD corrupted or something wrong with the hard disk or software? I have just installed a brand new disk of Hitachi 320 GB but the disk persmissions are repeated just the same like earlier 250GB. By the way, I changed disk as apple authorised service agent suggested faulty disk as probable reason for boot up problems but this doent seems so. Please help

Answered! View the answer I have this problem too

Is this a good question?

Score 0
Add a comment

2 Answers

Chosen Solution

Start up in safe mode first to see if that resolves your problem.

If that doesn't work you might try startuping in Single-User mode, and then Force run the onboard Disk Utilty repair. (fsck -fy ) Here's how:

2. At the command-line prompt type:

/sbin/fsck -fy

3. Press Return. fsck will go through five "phases" and then return information about your disk's use and fragmentation. Once it finishes, it'll display this message if no issue is found:

  • The volume (name_of_volume) appears to be OK

If fsck found issues and has altered, repaired, or fixed anything, it will display this message:

  • FILE SYSTEM WAS MODIFIED *****

Important: If this message appears, repeat the fsck command you typed in step 2 until fsck tells you that your volume appears to be OK (first-pass repairs may uncover additional issues, so this is a normal thing to do).

4. When fsck reports that your volume is OK, type reboot at the prompt and then press Return.

Your computer should start up normally and allow you to log in.

If this answer was helpful please remember to return and mark it Accepted.

Was this answer helpful?

Score 1

Comments:

Thanks for your suggestions. I started MBP in safe made and ran disk utilities. Verified disk - no errors were found. Ran verify disk permissions - lots of errors were shown - ran repair disk permissions - repaired - again ran verify disk permissions - same errors showed up again.

so u started in single user mode and ran the process as u suggested. Once in first run I got the msg FILE SYSTEM WAS MODIFIED. so I repeated the step 2 instructions and finally got the answer that volume is OK.

After rebooting, the MBP gave a msg RUNTIME ERROR DETECTED IN MAC HD and it got stuck at spinning gear and a msg came to shut down the computer. I powered off the MBP and restarted and I could log in.

It seems the problem is not resolved. What to do next?

by

I suspect your HD even though new it can fail. I would be contacting the vendor. Hitachi does have a bit of a reputation for poor QC. Since it's new I'd make them stand behind it... sadly you'll get no recompense for your time/labor.

by

Add a comment

Hi here are the list of errors that you can safely ignore(if these are flashing on your screen) http://support.apple.com/kb/ts1448

Was this answer helpful?

Score 0
Add a comment

Add your answer

milind will be eternally grateful.
View Statistics:

Past 24 Hours: 0

Past 7 Days: 0

Past 30 Days: 1

All Time: 1,416