Student-Contributed Wiki

Student-Contributed Wiki

An awesome student from our education program made this wiki. It is not managed by iFixit staff.

Samsung POWERbot VR9000 Troubleshooting

This troubleshooting page will help you diagnose problems with the Samsung POWERbot VR9000 (model number: SR20H9050U).

POWERbot Moves Erratically ¶ 

Your POWERbot does not methodically sweep an area and is either moving across the room diagonally or is taking circuitous routes.

Your POWERbot is moving around erratically likely due to the POWERbot's dust sensor functionality. When the dust sensor is turned on and the POWERbot detects dust, it will move in a pattern around the dust until no more dust is detected before continuing its cycle. If you wish to normalize the POWERbot's cycle, turn off the dust sensor using the POWERbot remote. Push the "dust sensor" button located in the lower middle portion of the remote. The "smart" LED located on the bottom right portion of the POWERbot's display screen should no longer be illuminated.

POWERbot Does Not Charge ¶ 

Your POWERbot does not seem to be recharging at the docking station.

Docking Station has No Power ¶ 

Check if there is a red plug icon at the top of the docking station. If the icon is not lit, the docking station does not have power. Verify the cord is securely plugged into the back of the docking station and that the AC adapter is securely plugged into a working outlet. If necessary, test the outlet by plugging in something else, such as a lamp. If the docking station still does not get power, the docking station may need to be replaced.

Charge Does Not Transfer ¶ 

Check if there is a green charging icon at the top of the docking station when the POWERbot is at the docking station. Verify that the docking station is level and that the POWERbot is properly aligned with the docking station. If icon is not lit, the POWERbot is not receiving charge from the docking station. Flip the POWERbot over and turn the emergency switch next to the battery cover off and back on again. Verify that the charging pins in front of the brush are clean and free of debris. If the charging pins are dirty, wipe the pins with a dry cloth or rag. Place the POWERbot back upright and realign the POWERbot with the docking station. If the green charging icon still does not light up, the POWERbot's battery may need to be replaced.

POWERbot Shows an Error Code ¶ 

Your POWERbot's display screen displays one of the following: 'C 01', 'C 02', 'C 03', 'C 04', 'C 05', 'C 06', or 'nobatt'.

Find your displayed error code below and follow the instructions.

C 01 : Object Caught in Powerbrush ¶ 

An object is caught in the power brush. Flip the POWERbot over and turn the emergency switch next to the battery cover off. Then, take out the power brush and clean it. Turn the emergency switch back on.

C 02: Object Caught in Left Wheel ¶ 

An object is caught in the left driving wheel. Flip the POWERbot over and turn the emergency switch next to the battery cover off. Then, take out the left driving wheel and clean it. Turn the emergency switch back on.

C 03: Object Caught in Right Wheel ¶ 

An object is caught in the right driving wheel. Flip the POWERbot over and turn the emergency switch next to the battery cover off. Then, take out the right driving wheel and clean it. Turn the emergency switch back on.

C 05: Bumper Sensor Error ¶ 

The bumper sensor needs to be checked. Flip the POWERbot over and turn the emergency switch next to the battery cover off and on again.

C 06: Dirty Obstacle Sensors ¶ 

The obstacle sensors are dirty. Flip the POWERbot over and turn the emergency switch next to the battery cover off. Then, place the POWERbot back upright and clean the obstacle sensors on the brush segment of the POWERbot. Turn the emergency switch back on.

C 07: Dirty Cliff Sensors ¶ 

The cliff sensor is dirty. Flip the POWERbot over and turn the emergency switch next to the battery cover off. Then, clean the cliff sensors in front of the driving wheels with a soft cloth. Turn the emergency switch back on.

nobatt: Battery Malfunction ¶ 

The battery has malfunctioned or a wire has disconnected. Flip the POWERbot over and turn the emergency switch next to the battery cover off and on again. If the error code persists, the battery may need to be replaced.

POWERbot's Suction is Weak ¶ 

Your POWERbot is not properly vacuuming the areas it passes over.

Battery Charge is Low ¶ 

Check the POWERbot's current charge via the display screen. If the charge is low, move the POWERbot to the docking station.

Dirty Brush ¶ 

Inspect the brush on the underside of the POWERbot. If the brush is dirty, remove the brush and clean it.

POWERbot Fails to Return to Charging Station ¶ 

Your Powerbot does not automatically return to the charging station after a cleaning cycle.

Blocked Path ¶ 

Your Powerbot fails to return to the docking station as it cannot find the docking station. Make sure your charging station is placed in an open area free of possible obstacles so that the Powerbot can easily navigate to it.

Insufficient Power ¶ 

Your Powerbot fails to return to the charging station as it runs out of power before can make it back. This is the result of a non-fully charged battery. See 'POWERbot Does Not Charge'.

6 Comments

Please help. Red light is on I've clean the area in front of brush clan doing station done everything clean all brushes but will not charge

Barbara Seckel - Reply

Just taken vr9000 out of the box, charged up, full battery pressed auto, it goes backwards a few inches then says error c07, which is clean cliff sensors! Ridiculous! They're clean as you'd expect, wish I never purchased this.

Paul - Reply

Hi

my powerbot is showing as fully charged. The docking station lights are working and the three bars on the powerbot are showing in blue as charged. The powerbot will not leave the docking station, I've followed everything in manual to check for issue and no resolve. There are no error codes being displayed. The best I can get is switching on and off, once switched back on manually it does a count down from 5-1 but then nothing. Also does not respond to remote or by manual input. I'm perplexed! Any recommendations?

Linda - Reply

My powerbot is doing exactly the same! I tried everything, nothing helped. Any ideas?

Eve -

My Pbot is NEW and has NEVER charged. I even paid for a service contract thru Amazon and can get NO support from Samsung. Any Advice???

ncjocn C - Reply

See above. I am very sick and too weak to deal with this!!!

ncjocn C - Reply

View Statistics:

Past 24 Hours: 36

Past 7 Days: 208

Past 30 Days: 943

All Time: 3,313