Student-Contributed Wiki

Student-Contributed Wiki

An awesome student from our education program made this wiki. It is not managed by iFixit staff.

Clippers won't turn on ¶ 

Clippers won’t turn on no matter what or they work intermittently.

Switch is turned on/device plugged in ¶ 

Make sure the power switch is completely rotated to the on position and that the switch is not too loose. Make sure that the power cord is securely plugged into an electrical outlet (with appropriate voltage), if the clippers fail to operate.

Motor is dead ¶ 

It is possible that the motor will not move because it is just jammed or needs cleaning and lubrication. The motor may also require replacement if this does not solve the problem.

Cord is frayed ¶ 

Examine the cord, including the plug, for signs of wear. If it is frayed and then be sure to replace the cord. Do not store the hair clipper with the power cord wrapped around the casing as this can damage the cord.

Clippers not cutting close enough ¶ 

Clippers do not cut hair close or snags hair in stead of cutting it.

Clippers have missing or defective parts ¶ 

Clippers are leaving gaps of differing hair lengths when they pass over the scalp. It is possible that your guards or blades may be missing some parts. Carefully inspect your guards or blades to see if they are missing any teeth. Another cause for these cut gaps could be interference from foreign objects. Your blades may not be adjusted properly or you may have dull or rusted blades. If so, replace the missing or defective parts.

Device vibrates excessively ¶ 

Clippers are vibrating more than usual and are very loud.

Missing or defective parts ¶ 

Missing parts such as screws or a cracked casing can be the cause of your clippers malfunction.

Improper adjustment ¶ 

The clippers may be improperly adjusted due to normal wear and tear or from being dropped enough times.

Clippers running slow ¶ 

Clippers may be running slower than usual and taking several passes to cut hair.

Cord may be malfunctioning ¶ 

Inspect the cords connections to see if there are internal wiring issues that could limit clipper power, such as arcing or a wire break.

On/Off switch may be malfunctioning. ¶ 

Inspect the switch mechanism for signs of pitting and arching. If it's not clean and doesn't make contact then the correct amount of current will not flow to the motor.

Motor may require replacement. ¶ 

The motor may be beyond repair and need to be replaced. Hopefully this is not the case because the Andis clippers usually don't have a significant manufacturer's warranty and the price of the motor is fairly hefty.

7 Comments

Hello, I have an andis envy adjustable blade clipper. I have used it only a few times(maybe five). The last time I tried to use it, it buzzed very loud and the blades were not moving to cut. Not sure what to do. Help please!

acerocke - Reply

Red wire came out the coil

Tyrone - Reply

How do I fix it

Tyrone - Reply

I dropped a pair of Styliner ii trimmers from countertop height and the motor stopped vibrating effectively, it only drew the armature to the field assembly, never repelling it to create the oscillations. It still vibrated but it was more quivering and chattering if I pulled the armature away. Something broke in the frequency or I'm not sure what exactly. I'll be ordering a replacement field assembly and see how things go and report back here. Not sure what could have failed in the unit that would cause the field to set one polarity.

jxramos - Reply

Turns out not to have been the field assembly but the anchor screw which somehow fractured previously and was shortened by the previous owner. I replaced and clamped down and set all the screws I could down with loctite made, adjusted the power screw and I was back in business.

jxramos -

I just bought my andis gtx outliner and I can’t get it to run. Other than plugging it in and turning the switch is there anything I have to do so it turns on?

estrada.fidel23 - Reply

I brought andia t outliner. The first one didn't cut even the blade was moving. My dad brought it back and exchanged it . The second one did the same so I sent it to the company. When I got it back it would cut sometimes. But still not like it should I have changed the blade now and it works ok sometimes but still not all the time. Any thing else I can do? I have spent alot of money and idk what else to try. A coworker loved hers she brought yrs ago.

BellaFrice - Reply

View Statistics:

Past 24 Hours: 26

Past 7 Days: 205

Past 30 Days: 863

All Time: 24,063