Early 2011 model, A1278 / 2.3 GHz i5 or 2.7 GHz i7 processor.

650 Questions View all

No sound - no sound devices found, but speakers are working,

Hi,

I've recently got a MacBook Pro up and running (got it from a friend who had spilt coffee in it). I fixed it by replacing the keyboard. But there's still no sound on it, and there has never been since I got it. If I go look in the System Preferences there are no devices to be found.

I thought the speakers were broken, so to be sure I connected them to another MacBook, and they worked! So now I can't figure out what the problem can be.

Can anyone help me with this?

Thank you!

Oh, and when I try the volume controllers on the keyboard, I just get this: http://i.imgur.com/tl53A.png

Answered! View the answer I have this problem too

Is this a good question?

Score 0
Add a comment
Father's Day Gift Guide
Let’s honor more than our dads—let’s celebrate all the mentors who taught us how to fix.
Father's Day Gift Guide
Let’s honor those who taught us how to fix.

1 Answer

Chosen Solution

Sounds like your Sound Card (no pun intended). Unfortunately there is no separate card/part for these machines. You might work around this with a USB audio dongle... USB sound might still work. Look in System Profiler (Information):Audio (Built In) to see if that is detected.

If this answer was helpful please remember to return an mark it Accepted.

Was this answer helpful?

Score 1
Add a comment

Add your answer

Mark Paul will be eternally grateful.
View Statistics:

Past 24 Hours: 0

Past 7 Days: 0

Past 30 Days: 3

All Time: 901