iPod Touch refuses to restore?

Okay, so I got a "for parts" iPod Touch 2G off eBay the other day because it said cracked screen and it wouldn't come on.

Thing is, I can put it into both DFU and Recovery mode, and it gets recognized in iTunes, but whenever I try to restore to 4.2.1, it perpetually gets stuck "preparing iPod for restore" and eventually times out, giving me an error ranging from 1600 to 1603.

That said, I used iReb and that worked once, the iPod became fully functional again (including LCD, surprisingly), but about 15 seconds after I pulled it off the charger, it shut off despite having at least 66% battery life.

Overall, I'm very confused and could use any help I can get.

Answered! View the answer I have this problem too

Is this a good question?

Score 0
Add a comment

1 Answer

Chosen Solution

Dustin, not sure if you have tried this yet. the other thing I definitely would do is to change the battery. Your iPod is getting to the age of where the battery can easily fail. iDevices behave weird when the battery goes crummy.

Was this answer helpful?

Score 1


Seems like battery replacement might be my best option here, since I've done every possible solution listed in the link you provided (some multiple times) to no avail. Even right now, after using iReb, it refuses to restore and gets stuck in the perpetual "preparing iPod for restore" state till it times out.

At any rate, thank you for your assistance, I really appreciate it.


Sounds good, let us know how it turns out.


Add a comment

Add your answer

Dustin will be eternally grateful.
View Statistics:

Past 24 Hours: 0

Past 7 Days: 2

Past 30 Days: 5

All Time: 1,074