Fifth generation of iPhone. Repair of this device is straightforward, and requires screwdrivers, prying tools, and patience. GSM/CDMA / 16, 32, or 64 GB / Black or White.

2885 Questions View all

Dropped and now wont restore even though in recovery mode ( error -1 )

Hello,

I have an iphone 4s that was dropped and worked fine for a bit but when i went to restore it now wont resotre it without getting error -1 hardware issue.

What hardware could be the problem? Is it hardware?

I've tried doing a shift and restore from download firmware. Any ideas what else i could do ?

Answered! View the answer I have this problem too

Is this a good question?

Score 0

Comments:

Hi, I have the same problem with an iPhone 4 of a friend that had a big crash. First it turned on but it displayed that the iPhone 4 need a restore because it cannot send and recieve calls. I tried to restore it but iTunes gives me the same error (-1). Anyone have a solution?

by

Add a comment

1 Answer

Chosen Solution

I would recommend restoring the phone on a different computer. I had that error code before and using a different computer allowed it to successfully complete the restore.

another possible scenario if you are willing to tackle...

It could be a bad charge port on the phone. You might try replacing it. I also had that situation before as well.

Was this answer helpful?

Score 0
Add a comment

Add your answer

ben will be eternally grateful.
View Statistics:

Past 24 Hours: 0

Past 7 Days: 0

Past 30 Days: 1

All Time: 1,189