iPod Classic

Model A1238 / 80, 120, or 160 GB hard drive / black or silver metal front

632 Questions View all

Why is my iPod not charging

I got an I pod with what I thought was a bad battery so I replaced the battery and it worked perfect until it came time to charge. When I plug it in the I pod has the charge screen and the battery symbol says it's charging but when I disconnect it the battery bar doesn't move. I used it until it died and now it just stays at the screen that says please wait very low battery. Is there a part I can replace or is it just done?

Answered! View the answer I have this problem too

Is this a good question?

Score 0

Comments:

Have you had a look at the charging pins and cleaned them?

by pollytintop

Add a comment

2 Answers

Chosen Solution

Wesley, it is possible that you do have a bad battery. It is also possible that your dock connector has some issues. Make sure that you have a good cable, that you try a different USB port as well as a wall charger. Clean the dock connector of any dirt, debris like pocket lint, and check for bend broken and corroded pins. The battery connector is finicky and has a tendency of breaking of the logic board, so be careful. If none of that works, you may have a bad power management IC on your logic board. Remove the front of your ipod and on the bottom left, opposite the battery connector, you will find an IC. That is the LTC4066. It is the USB power manager and Li-Ion battery charger. The LTC4066 monitors the battery charge state and temperature. When the battery is charged, it quits supplying power to the battery. Make sure that it is not destroyed. Check for obvious external damage. You can get the data sheet for the IC from here. You could use that to see if that is your problem. Also check on the fuse F1 and use a multimeter to see if you have continuity. Of course the other thing you could do is to replace your logic board which should run anywhere from $45 to higher. Hope this helps, good luck.

Block Image

Was this answer helpful?

Score 2

Comments:

Ok I have my I pod open and I am to the logic board similar to the one pictured but it doesn't have the power management IC or the fuse that I can find I may have a different generation but I'm not sure

by Wesley

I may be an I pod video 5 gen

by Wesley

The metal piece around the dock connector is broken on one side. It doesn't appear to inter fear but that might be the problem and if so is it possible to fix that.

by Wesley

If it is a 5th gen it's an iPod Video (not a classic) the same IC is on the board but it is in the top left corner. Same principal as for the iPod Classic. The metal shield should not be a problem, unless it is providing the ground as well as creating a short circuit. Check for all the contacts, use a magnifying source. In order to fix it you will have to solder it.

by oldturkey03

Does the video have the fuse as well?

by Wesley

Show 1 more comment

Add a comment

HI Oldturkey,

I know this is an old thread but hopefully you are still active.

I have an iPod classic which will not charge the battery or sync.

I have tried 3 known good batteries etc and have also checked the fuse and also replaced the Power IC.

I have checked the battery connector and it seems solid, it is also receiving voltage to the battery connector.

Before I go about replacing the notorious docking port, are there any other Mosfets or Diodes I could check that you can think of? There doesn't seem to be any corrosion on the board and it the ipod itself is in pristine condition

Thanks

Was this answer helpful?

Score 0
Add a comment

Add your answer

Wesley will be eternally grateful.

View Statistics:

Past 24 Hours: 30

Past 7 Days: 150

Past 30 Days: 717

All Time: 11,037