MBP A1226 doesn't boot on SL on a SSD

Like so many people, I installed a SSD in place of the HD, and shifted the HD in a SATA/ PATA caddy, in place of the DVD...

Then I did a clean install of SL 10.6.8, migrated applications and data.

But the MBP is unable to boot on the SSD.

I can have it boot after disabling extensions (shift key) or "manually" when selected after holding the option key at start-up. Not very convenient, hum?!

Any idea? Because of this problem, I tried another brand of SSD (SanDisk; the first one being an OCZ Petrol. both in SATA III). The same problem occurred.

I was told to update to Lion, who is supposed to fix the problem but I don't want to (I need some Rosetta softwares). I can't believe pre-unibody MBP 153 just don't accept SSDs! This would have been displayed on the best Websites and forums like the iFixit ones!

Thanks for your thoughts and solutions!

Answered! View the answer I have this problem too

Is this a good question?

Score 0

Comments:

How quickly are you giving up on that boot? Sometimes that first boot from an update can take quite a while.

by

Thanks Machead3.

I gave up after 15 mn (coffee then sooo many other things to do!).

I did that repeatedly (without coffee), as an attempt to overcome the "random behavior" I noticed: with the OCZ it boots, say, 90% of time when option key is holded and SSD selected. With the SanDisk the percentage comes down to 0% approx...

by

Add a comment

1 Answer

Chosen Solution

Could be a dead backup/CMOS battery that should be holding your boot drive (startup disk) preference. It's a non-recharging long-life Lithium coin cell. I think a BR 2032 or equal, you should be able to change that yourself.

If this Answer is helpful please remember to return and mark it Accepted.

Was this answer helpful?

Score 0

Comments:

Thanks again, Machead3.

Well, this is a potential option I didn't think about...

But could you tell me about the reason to think that the boot from a HDrive (it being in HD slot or DVD slot) would solicit the battery less than the boot of a SSD? I can't think about such reason right now...

Could that happen with a "weak" battery, starting to decrease its voltage???

by

It might - if the battery is going or gone the preference as to where the boot volume is hasn't changed... so if the boot volume is in the old place - bam your good, if it's not the computer hangs looking for a boot volume.

by

Good evening and thanks again!THE solution was actually simpler (almost to simple, as you will see!): I brought the MBP to the Genius bar f the local Apple Store. They reinstalled the 10.6.8, as the first step of investigation.

Saying that they'd seldom heard of a problem with the upgrade of such 2007 MBPs with a SSD.

And it simply worked...

I'd used a genuine DVD SL 10.6.1 or 2 plus the combo upgrade straight from apple.com; and I did the entire stuff twice, with each of the SSDs I tried...

So, was nice to see the straightforward approach of the guy there, despite the age of the machine, despite my obvious do-it-yourself approach...

The MBP is even faster than during the few times I was able to boot it from the SSD, earlier on. So, it seems it really was a system installation/upgrade issue...THanks anyway, Machead3!

by

Add a comment

Add your answer

Jean Luc will be eternally grateful.
View Statistics:

Past 24 Hours: 0

Past 7 Days: 0

Past 30 Days: 0

All Time: 807