Charging station now giving steady voltage and Roomba not charging


I recently purchased a faulty Roomba 676 and wanted to try to fix it. The problem was it not charging. I tried to charge it on a 676 station and it worked fine, so I assume no issues with the Roomba itself.

I tried measuring the voltage from the station pins and it was fluctuation between 0 and 10 V, which the good station does not do.

I open the station up and find 2 different PCBs, one working as the PSU and the other with the intelligence. The boards are connected with wires. I cut the wires and try to measure the voltage coming from the PSU board and it is also fluctuating between 0 and ~23 V. When I connect a seperate PSU directly to the "intelligent" PSB, I get a steady 2V out and when I connect the pins with a 10K resistor, the voltage ramps up to about 20 V, so I would say that PCB is working as it should. The problem is somewhere in the PSU PCB.

Measurement after PSU PCB

Block Image

Measurement of the charging pins

Block Image

Block Image

Answer this question I have this problem too

Is this a good question?

Score 0
Add a comment