Skip to main content

Repair guides and support for all-in-one washer and dryer assemblies as well as stacked units.

141 Questions View all

AEG Washer/Dryer stops part way through drying cycle, no error code

Hi everyone, looking for some tips with a mysterious failure in the drying cycle. Many thanks!

AEG washer/dryer Kombi, 7000 DualSense, model L7WEG841R. Bought new in mid 2021.

Washes fine but drying cycle gives up a few minutes after starting - as soon as the sound of air blowing begins, the time countdown skips down to 10 minutes, and it wraps up the cycle. I think no heat has reached the clothes. No error codes at any point.

Detail of an example problematic drying cycle, set for 1:06 hr drying time:

  • Counting down from 1:06 to 0:56, does stuff more like a slow spin in the washing cycle.
  • At 0:56 starts blowing air like the dryer usually does.
  • The Problem: 30 secs later timer skips down to 0:11.
  • Continues blowing while counting down. Reaches 0. Beeps a few times. Stays locked almost 10 mins with occasional small drum movements, then unlocks. Didn't feel like any heat had reached in.

Update (27/10/23)

I was able to get the machine to tell me an error code by holding down two of the control buttons. E73. whitegoods indicates that's about the NTC sensor:

  • Fault in NTC sensor on drying duct (voltage out of range = short-circuit, open circuit)
  • Drying NTC sensor (duct) faulty
  • Wiring faulty

I think that's the "temperature probe" part 470 on the dryer parts diagram.

Update (10/24/23)

Not an answer, just a placeholder for the image of a controller part

Block Image

Answer this question I have this problem too

Is this a good question?

Score 0

Just to say, I am getting exactly the symptoms you describe on a L8WEC166R. Interested how you managed to generate a fault code, but I am guessing this may be with some diagjostics equipment. I was also confused why it affected timed cycle as well, but came to the conclusion that it may still be using the moisture sensor to prevent overdrying. My next step was going to be replacing the moisture sensor but struggling with time to take it apart at the moment. As you say, if that is not the problem, then a controller issue would be the next thought. But in my limited experience of controller faults, these generate much more unpredictable symptoms which is why I am not considering this as the likely culprit for now. Also it is expensive as you say.

Did you advance on diagnosing and fixing the fault here? Would be helpful if you have further updates.


Hi Herman, the fault code wasn't hard to get, using a "hidden" button combination. I think I got it from .

I'm just getting back to trying to fix this, been using a dehumidifier and drying rack, which works surprisingly well. And if I mess up and knock out the washer as well, that would be a proper domestic disaster. Will update as soon as I have something.


Add a comment

3 Answers

Most Helpful Answer

Hi, I had the same problem and it turned out that the front sensor cables were broken. Because they are attached to the warm air pipe, they burn and harden over time, causing them to break.

Block Image

Was this answer helpful?

Score 1


Exact same thing that happened to mine


How do I replace that myself?


Add a comment

I'm guessing since I don't know this particular combo. If the mode is detecting dryness level rather than timed, and it thinks the clothes are dry it will shorten the cycle. That would also explain why there is no error code.

I am assuming the 10 min lock is to allow it to cool down - even though it apparently isn't heating. And it probably isn't heating because it thinks the clothes are dry.

Can you set it to a timed dry cycle? If so, does it dry?

If it does dry on timed, the first thing to check is the dryness sensor.

If it doesn't dry on timed, then the controller.

If there isn't any timed, it could be either the sensor or controller.

Was this answer helpful?

Score 0


Thanks Bill!

Unfortunately problem affects both timed and sensor-ed cycles. By controller do you mean the part in this screenshot? It's costly enough to try and confirm mine is broken before going for a replacement - any tips for how to do that?


Thanks again!



how does it affect the timed function?

The controller would be parts with electronics. 587, 587A, 586. I can't tell what the other parts are. If I had a schematic I might could help you troubleshoot it, but without that I can't tell you if something else might be causing the controller to shut it down. I assume you know how to operate it and it has been working for you in the past. If not, it could be cockpit error, like being set to minimum dry, or not getting it into dry mode properly. That seems to be a problem with many combo units per other posts on the inet.


The drying attempt in my question was a timed one. The same thing happens with timed or sensor-ed. It was working fine, this problem appeared at some point and has been happening every time since then.

I hoped that clearing out some gunk from behind the door seal would help. It's very awkward to get in there to clean it, but I did, and it didn't make a difference. Drain filter is clear.

I'll try a diagnostic/test cycle, but it's looking like I'll need to get someone in to look at it. Hopefully they'll have access to service manuals etc, I haven't been able to spot anything myself.


Add a comment

Did you solve this problem Alex? I have the same model with the same issue. I’ve replaced the NTC sensor but that didn’t solve it

Was this answer helpful?

Score 0


Hi Jonathan,

Having done some more detailed troubleshooting I solved the problem on a L8WEC166R which i think is probably of a similar design.


Select automatic drying cycle, after a couple of minutes, the display time goes down to 14 minutes which is the cool down stage of the cycle. Same symptoms when selecting a timed drying cycle.


I switched the machine into service mode (see ) and selected function C11 last error code. It displayed E73 which is a sensor issue.


After googling E73 Error code I tried replacing the NTC (humidity sensor) located on the back of the drum but there was no change in symptoms. Then I identified the three sensors located on the hot air duct, and identified these as thermostats. I replaced them one by one, and found it was the second one that had failed. You could also replace the gaskets/o-rings on these thermostats, but I didn't feel the need to. Thermostat total cost £40 from Ransom


Thanks for that Herman. I had replaced one sensor at the front of the hot air duct hoping that would solve the issue and started to consider changing the other two before watching a YouTube video last night where a gentleman suggested checking the wires that lead to the front sensor. I unwrapped the sticky tape on the wires to find they had both been completely separated so I think I’ve finally solved the mystery. Fingers crossed this does the trick but if not I’ll take a look at the other two sensors. Appreciate your help sir.


I have same issue on AEG L7WEC166R.

I jumped the gun and replaced both NTC sensors (heater duct and rear of drum) and it did not rectify fault.

After that I did what I should have done from start and metered both the sensors. Started with one on front of heater duct and measured at spade connectors on sensor. Measured around 7k ohm which is normal for ambient 13C. Measured to ground and open circuit.

Measured one on drum at connector and it also measured 7k, good sign.

The sensor on heater duct has a connector on wiring as it travels along top side of machine, checked here and also 7k.

Next step would have been to check at dryer control board but it is a faff to access it.

I got frustrated and put it all back together and its working!

I can only presume it was a bad connection on the connector for heater NTC sensor. Reseating it must have helped.

I checked the old sensors in hot water to rule that out and they behaved normally.

Moral of my story is I should have done some fault finding first.


For anyone wondering about the thermostats in the dryer and NTC sensors here's my understanding after spending few hours on it.

The top heater duct has 2 stats and one NTC.

A manual reset thermostat. This is a fail safe to cut out the heat if the main stat fails. It's a simple on/off and has a red button.

Heater control thermostat. I believe this cycles heat on and off. If it failed open you would have no heat and if it failed closed it would trip the manual one.

An NTC sensor. This is a thermistor type and feeds back actual temperature to dryer control board.

There is also an NTC sensor on rear of drum which is also a thermistor feeding back actual temperature.

The dryness sensing works by comparing the air temperature entering the drum with air temperature leaving.

The idea is that while the clothes are wet the temperature on exit should be lower.


Hi everybody. Also thanks to your posts I solved my problem that was exactly the same.

I removed the top panel and unplugged the three temperature sensors. Doing this, I noticed that as for one of these sensors the connection was non firm and plugs had become oxidate.

I removed oxidation with sandpaper, replugged cables and it worked for me. Now my aeg 7000 kombi series dries again. Hope this can help.



Show 1 more comment

Add a comment

Add your answer

Alex Iliev will be eternally grateful.
View Statistics:

Past 24 Hours: 11

Past 7 Days: 44

Past 30 Days: 237

All Time: 1,543