Why are some of my NES games not reading the controller input

So last week I went to a retro gaming convention last week and I bought paperboy and Dirty Harry on nes along with other few nes games and when I got home I cleaned them and tested them and all of the nes games that I bought at the convention worked except for paperboy and Dirty Harry both games seem to run normal until when I tried pressing all the buttons both games would not start at all,I tried swapping the controller ports and pretty much nothing for Dirty Harry and for paperboy when the game goes on to demo mode I press either select or start and the game stars going to the player select screen but the game still doesn’t let me continue playing the actual game it just keeps going to demo mode and after that I tried testing every nes game that I had in my collection and all of them seem to work fine except the last star fighter which baffled me because the last time I played that game it had absolutely no issues with controls and worked fine and I quickly noticed that all the games that had issues with not reading the controller input where games that mindscape developed/published and I wanna know if it’s the issue with the cartridges,the console or the controller

Answer this question I have this problem too

Is this a good question?

Score 0
Add a comment