Why doesnt my ds3 charge batteries?

My OEM controller doesn't charge, no matter how long you leave it charging when you remove the cable it tells you to put it back and will turn off after few mins. So I did the obvious and swapped the battery but same story its always empty. After that I put the old battery in my fake controller and it works and charge that means the battery is good, so i charged it and put it back on my original contoller and that worked, but I don't want to keep removing the battery to keep playing (my fake controller have some input issues thats why i don't use it). I don't know how but twice the controller managed to charge the battery i put it for some time and it was 2 bars and today it went to one bar after i removed the cable but it stops there . the problem here is that when its plugged with the ps3 it shows that its charging in the battery pic but i don't know why the battery is empty. So I tried 3 different cables, charging it on pc, ps3 and on my tv nothing works. Anyone got a solution?

Answer this question I have this problem too

Is this a good question?

Score 0
Add a comment