Skip to main content

A laptop by Lenovo that can function as a tablet.

45 Questions View all

USB-A port stopped working. (USB xHCI Compliant Host Controller)

Hi - Unsure why USB-A is can't be detected anymore.

  1. Tried reinstalling drivers
  2. Even removed the drivers manually so that correct driver can be reinstalled
  3. Reinstalled windows 11 from the scratch
  4. Ran Lenovo softwares for diagnostic, no issue found, all drivers are Up-to-date
  5. Tried to boot from USB, but port not detected

I think all possible combinations have been tried in BIOS

  1. Tried turning switching 'Always ON' flag in BIOS
  2. Disabling 'secure boot' to boot from the USB
  3. Restoring BIOS to previous version
  4. Upgrading BIOS
  5. Resetting BIOS to default

No other option seems to be related to USB-A in the BIOS.

Also tried:

I tried "USB Root Hub - Properties - Power Management and check if the box that says "Allow the computer to turn off this device to save power" is unchecked."

Also tried:

  1. DISM /Online /Cleanup-Image /RestoreHealth
  2. sfc /scannow

Did anybody else faced this issue?

Thanks

Error in Device Manager:

This device cannot start. (Code 10)

{Operation Failed}

The requested operation was unsuccessful.

Answer this question I have this problem too

Is this a good question?

Score 0
Add a comment

3 Answers

Most Helpful Answer

Hi,

Just verifying that the USB-A host controller is not shown in Device Manager, is this what you mean?

If it is there but the port is not working check if there is power being supplied by the port e.g. insert a mobile phone to see if it shows it's charging or insert a USB mouse and check that the laser light turns on.

If there is no power on the port then go to Device Manager - click on > symbol to the left of Universal Serial Bus Controllers to expand the list - right click on USB Root Hub - Properties - Power Management and check if the box that says "Allow the computer to turn off this device to save power" is unchecked. If it is checked, uncheck it then click OK (I don't know which Root Hub entry is tied to the USB-A controller so you may have to check all of them)

Restart the laptop and check if the USB port now works OK

Was this answer helpful?

Score 1

2 Comments:

Thanks for the reply.

USB-A Host control is showing under UNKNOWN devices under Device Manager with error which I provided earlier. The name of the controller as shown is "USB xHCI Compliant Host Controller".

There is no power to the USB.

I tried "USB Root Hub - Properties - Power Management and check if the box that says "Allow the computer to turn off this device to save power" is unchecked."

Also tried

DISM /Online /Cleanup-Image /RestoreHealth

sfc /scannow

Thanks

by

@Jkam

Try disabling the USB selective suspend setting and check if that resolves the problem.

Go to Control Panel > Power Options > preferred plans (whichever you have selected) > Change Plan Settings > Change Advanced Power Settings > USB Settings >USB Selective suspend setting > Disable > Apply and then restart the laptop.

With laptops there should be 2 options On battery and plugged in, you can disable it in both.

by

Add a comment

Hv you looked in the bios to see if there is anything having to do with that port ?

Was this answer helpful?

Score 0

2 Comments:

Thanks for your reply.

I think all possible combinations have been tried.

# Tried turning switching 'Always ON' flag in BIOS

# Disabling 'secure boot' to boot from the USB

# Restoring BIOS to previous version

# Upgrading BIOS

# Resetting BIOS to default

#

No other option seems to be related to USB-A in the BIOS.

by

Thecod3r on YouTube this young man is a genius you could send it to him or tronikfix he is on YouTube also I don't hv the unit hear so I'm in texas

by

Add a comment

Hi experts

I have HP PROBOOK 640 G2 laptop

I have a big problem in its USB ports all ports does not work in OS but works in BIOS

I try to boot to LINUX OS using USB flash as livebooting it works at first but stop at the mid of boot process also I try to install windows 10 from USB flash and works at first installation steps but stop at the mid of installation

also when shutdown the laptop the WIFI and sound buttons remain on and the fan and keyboard some time remain on

I update the BIOS to latest version but the problem still exists

I also tried all software solutions in the Web include latest drivers but all fails

the problem in devices manger shown in attached picture

please help me to get the solution

Block Image

Was this answer helpful?

Score 0
Add a comment

Add your answer

Jkam will be eternally grateful.
View Statistics:

Past 24 Hours: 6

Past 7 Days: 22

Past 30 Days: 76

All Time: 1,291