Skip to main content

Why is my laptop not able to turn on.

I have a Lenovo IdeaPad S145-15IWL and used it since 2018. Recently, I dropped it on the floor (the laptop was closed with display-side down). In the following hour or 2, it seemed like my screen constantly broke. In the middle of using it, my screen would just go black with some areas of my screen displaying random pixels. This would get fixed by just restarting the computer but it would happen again after 10 or 20 minutes. After about half an hour, my laptop would just turn off with no way to turning it back on. When I press the power button, the power LED just lights up for a couple of seconds and then turns off. Then, I tried opening up the computer and reseating the RAM. I also checked for any severe damage. I couldn't see any but I've only opened up the bottom of the laptop and haven't checked the display. After that, I tried plugging it in and seeing if it would boot. To my surprise, it actually did. I didn't know why it booted since it wasn't on low battery and I could use it without plugging in after that. Then, that same problem where my screen would go black and display random pixels affected my computer but could be solved with just a restart. The laptop survived that day but I still was concerned whether serious damage was inflicted on it or not. In the beginning of the next day, I dropped the laptop again (closed with display side down). This time, the laptop refused to turn on and when I tried pressing the power button, the power LED would again shine of a couple seconds and turn off. I tried plugging it in but it didn't resolve the issue. I again tried to open it up but I didn't see anything off. My computer is now unable to be used and I've exhausted all my ideas. This is why I came here and asked you guys to help me solve this issue. This would also be beneficial to other people who might have the same problem as there is currently limited documentation about this laptop. Thanks!

Answer this question I have this problem too

Is this a good question?

Score 0

sorry to say but if your that bad at dropping it im surprised it even turned on, there is no documentation for dropping a laptop as thats not what they are intended for. chances are you have dropped it too many times and disconnected solder balls under 1 of the bga chips im not sure if that model has an indepentant gpu or not


The model does not have a independent GPU.


Add a comment

2 Answers

Most Helpful Answer

Hi random person,

Okay, to start with, you can download the Hardware Maintenance Manual for your laptop from Lenovo here.

Lenovo IdeaPad S145 Series Hardware Maintenance Manual

Start with the section titled "Power system checkout". Then check the status indicators for the AC power adapter and the Power status indicator to see if they tell you anything.

Next, we'll want to start with the basics; is the computer getting power at all? You've hopefully verified the AC adapter during the Power system checkout procedure, so we know that's good.

Next, we want to be sure power is getting to the motherboard from the power plug. Go to the first section of the Removing and replacing FRU section and remove the Base Cover, or the bottom case of the computer. From there you should be able to locate the power jack. Put a voltmeter on DC power and the range should be able to cover at least 20 volts, which you're looking for on the power jack. There should be a single pin coming out the back side going to the motherboard; that's the positive input and for the negative the case of the jack should provide the ground. You should see the same voltage as the output of the AC adapter, about 20 volts between those two points. Wiggle the plug and verify that the power doesn't cut in and out when you do to be sure there's no damage to the solder pads of the power jack.

Let us know what you find and we can go from there.

Was this answer helpful?

Score 1


When the battery is installed, the charging indicator lights up when I plug it in.

When the battery is removed, the charging indicator does not light up when I plug it in.

The power status indicator always lights up when I press the power button.

I also can't verify whether the power adapter is working or not as I don't have the proper tools to measure voltage.



I forgot about this question for a long time since I didn't remember to ping you on my previous comment so therefore, you didn't respond. After looking at other people's comments on other questions, I realized I needed to ping the author of the answer in order for them to get notified. This might be a little late but can you please continue to help me on this thread. Thank you.


Add a comment

Please check if the AC adapter connector is loose (marked in the image below: A-power cord plug / B-outlet side plug / C-NB side AC jack), or you can try connecting to different outlets. Please check if the adapter or cable is damaged. If there is any damage, please contact ASUS service center for further information



Was this answer helpful?

Score 0

1 Comment:

I don't see the image.


Add a comment

Add your answer

random individual will be eternally grateful.
View Statistics:

Past 24 Hours: 1

Past 7 Days: 5

Past 30 Days: 33

All Time: 351