Skip to main content

Repair information and troubleshooting for the Dell Latitude E5570. This is a 15.6 inch business class laptop computer with a 6th generation Intel Core processor. It was released in 2016.

7 Questions View all

An installed battery is not identifiable

Hello everyone,

A friend managed to get an old Latitude E5570 for cheap but it had a completely dead battery and missing power adapter. I'm trying to fix it as a challenge, so I got a new battery replacement, an (allegedly) OEM charger and a new CMOS battery (just in case).

Replacing the battery I immediately managed to power on the laptop and install Windows, but from the bios I can see that neither the battery nor the AC adapter are being recognised. The battery is an aftermarket one, while the AC adapter has the dell logo on it and was sold as genuine from here, although the laptop still doesn't recognise them.

Looking around I read that a bios update should fix the issue, so I installed the latest bios from the Dell website. I had to use the /forceit command to install it because it didn't like the lack of AC adapter.

The error I get from the bios is "an installed battery is not identifiable [...]" and then it goes on saying that it refuses to charge it. The battery is now slowly discharging and I'm afraid I won't be able to do anything on it anymore, once it's completely dead. I tried to power on the laptop without battery connected, but I only managed to get it to start up once and never again, I don't understand why. I also tried to do the reset procedure where you unplug battery and CMOS battery, hold power button, plug in CMOS battery and plug in AC adapter, but that only seems to work once too.

How do I get this laptop to charge properly with its new battery? Thanks!

Answer this question I have this problem too

Is this a good question?

Score 1

5 Comments:

Hi,

Try uninstalling the battery drivers in Device Manager and then restart the laptop and check.

To get to Device Manager in Win 10 , press the Win key + x key (both together) and click on the Device Manager link that shows in the menu.

In Device Manager, right click on the battery entry and click on Uninstall and follow the prompts.

Windows will auto install the drivers again once the laptop is restarted

by

@jayeff Thanks, I already tried and it didn't make a difference. Shouldn't the charging process be independent from drivers? The laptop doesn't even charge when it's powered off and simply doesn't recognise any charger.

by

@vongola

It should be.

Looking at an image of the charger it is a simple one i.e. only DC +ve and -ve applied to laptop, plus a third wire presumably used for ID.

Have you checked that the charger's output voltage is OK at the charger plug i.e. +ve 19.5V DC on the centre (inner) connector of the plug when measured between the inner and outer connector rings?

Also check that the voltage is OK on the red and black wires of the cable connected to the DC-In jack at the motherboard

by

@jayeff Hi Jayeff, I have checked with a voltmeter and I get exactly 19.5 V on the back of the connector (just on the motherboard). What else could it be?

by

To add to the current problem, I tried to reset the BIOS by removing the CMOS battery, main battery, hold power button and plug in everything again. After the reset, I get the following message: "WARNING: If a service tag was just installed, you will need to shut the system down and unplug the AC adapter if present. Re-insert the AC adapter and power on the system to allow for proper functionality. If a service tag was not just installed, then the primary battery is not identifiable. This system will be unable to charge the batteries until this battery is removed.".

To add to that, if I remove the battery and try to turn on the laptop without it, the laptop powers on for a second or two and then goes off again. So it is definitely getting "some" power from the AC adapter. I tried 4 different AC adapter that I have around and the laptop does the same thing with all of them...

by

Add a comment

1 Answer

If it is not seeing the charger and not charging the battery, it is probably an issue with the power input board. However, not all Dells have one. It could also be a broken/poorly soldered power socket inside the computer.

Was this answer helpful?

Score 0

4 Comments:

I tested it with a voltmeter and I can measure 19.5 V on the motherboard where the power socket is connected. Is there anything else I can check with a voltmeter?

by

The computer is trying to ID the adapter. The way Dell does that is via a third wire to the adapter for an I2C communication. It is possible:

1. The adapter is not the right one.

2. The center pin in the adapter plug is broken.

3. The socket connection to the plug is broken.

4. There is a problem with the I2C circuit. That would be a MB issue or a BIOS issue.

I can barely see the pin on my XPS adapter, but the socket has a center piece with a hole in it for the pin. The voltage is supplied via the outside sleeve and an inside sleeve, not a pin as in most adapters.

As for why it can't ID the battery either, that might point to a problem with the I2C circuit.

by

@ruggb The AC adapter should be compatible according to the manual. I've also been able to turn on the laptop with the battery unplugged using only the AC adapter. Would that be possible if the laptop didn't recognize the adapter? I also tried the same adapter on a much newer dell laptop and it works completely fine. Is there any circuit on the motherboard the only deals with charging the battery that might be damaged?

by

Your initial post said it was not recognizing the battery OR the adapter. If it does not tell you it is not a Dell adapter when it boots, then it is recognizing it. If you run "powercfg /batteryreport" from a cmd prompt, what does it tell you?

The battery charging circuit it internal to the computer. For Dell, some have a separate board, others are on the MB.

by

Add a comment

Add your answer

Rob Vongola will be eternally grateful.
View Statistics:

Past 24 Hours: 10

Past 7 Days: 46

Past 30 Days: 217

All Time: 5,154