Skip to main content

The K56CM is a 15.6-inch "ultrabook" laptop manufactured by Asus. It was first announced in 2012.

5 Questions View all

CPU fan is on, the battery is charging, but I have no image

Hello. I have the same problem… I just disassembled the laptop to clean, and when I assembled it the CPU fan is on, the battery is charging, but I have no image. Tried to connect to an external monitor with HDMI and VGA and didn’t work neither. Anyone have a solution?

@jayeff|new_window=true]++ Asus K56C

Answer this question I have this problem too

Is this a good question?

Score 1
1 Comment

@techrepairpt

Please verify the make and model number of the laptop?

by

Add a comment

1 Answer

Most Helpful Answer

Hi @techrepairpt

Try a full power refresh and check if that resolves the problem. It may be that a corrupted BIOS is preventing a normal start.

  • Turn off the laptop if it is on and disconnect the charger from the laptop (if connected).
  • Remove the main battery from the laptop.
  • Press and hold the laptop's Power On button for a full 30 seconds and then release it.
  • Reinsert the main battery, reconnect the charger and check if it turns on OK.

If still no good, try again but this time disconnect the RTC (Real Time Clock) battery (aka CMOS battery) as well before pressing the Power button for 30 seconds, then reconnecting the RTC battery, reassembling the laptop, reinserting the main battery etc.

Unfortunately this battery is mounted on the underside of the motherboard, so the laptop would have to be nearly completely disassembled to get to it.

This battery helps to maintain the BIOS settings when the laptop is turned off and when its voltage get too low the BIOS can become corrupted. Whilst the battery is out check its voltage, if it is <2.5V DC replace it.

Here's an image, showing where the battery is located on an Asus K56C motherboard.

Block Image

(Click on image to enlarge)

You may find that after the RTC battery is removed/replaced that when the laptop is turned on, there may be message saying that the date and time is incorrect. This is normal as the BIOS has been reset back to factory default. Once the D&T have been corrected the message won't appear the next time the laptop is turned on.

Was this answer helpful?

Score 2

1 Comment:

I removed the main battery and the charger, pressed and holded the power button for 30 seconds and it worked. Thank your very much!

by

Add a comment

Add your answer

Bernardo Rodrigues will be eternally grateful.
View Statistics:

Past 24 Hours: 0

Past 7 Days: 0

Past 30 Days: 6

All Time: 42