Skip to main content

Repair information for the Fitbit Sense. A smartwatch with GPS tracker, health and fitness sensors.

14 Questions View all

Fitbit sense in boot loop.

My Fitbit sense was working fine during a typical day. I had gotten a phone call on my iPhone and my Sense indicated it OK. After the phone call was complete the Sense still indicated the answer/cancel menu. I hit cancel and everything crashed after that. Now when I try to reboot with the USB jack plugged in on charge I get a brief indication that there's a connection with my windows computer after the screen goes blank but then there's a disconnect and the boot screen comes back. I tried letting the battery run down completely and then doing a recharge to maybe let the CPU reset but I didn't have any luck. My guess is that this is strictly a software issue but I've had no luck getting the Sense to restart properly. Opening up the watch and disconnecting the battery was another idea that I had but that hasn't been attempted yet. I have the tools to open up the Fitbit Ionic and have changed the batteries a couple of times in the past but I hear that doing that with the Sense is harder. At this point I have nothing to loose because my Sense in bricked and I just bought a new Apple watch. I like trying to fix electronics stuff and wouldn't be afraid to give it a try.

Answer this question I have this problem too

Is this a good question?

Score 0
Add a comment

1 Answer

Most Helpful Answer

Try a hard reset, Google how to do it. Have it connected to the charger whilst trying it.

Was this answer helpful?

Score 1

9 Comments:

I can't do this. All I'm getting is the FitBit logo (dot squares) on my watch. I hold the reset 'button' for a couple of seconds and the dots disappear and I release the reset 'button' and the dots will reappear. You can't do a factory reset because you can't get to settings because the software doesn't start up at all. That's my basic problem.

by

I didn’t mean a factory reset. hard reset as below.

https://youtu.be/bI9jqRilqOg

by

I am familiar with the hard reset. I've tried it about 100 times as shown in the YouTube video. After pushing the button on the side for about 20 seconds the screen goes dark and I release the button. Unfortunately the same boot screen comes right back and nothing more happens. I have even let the battery go dead and tried it again after recharging but always get the same results. Right now I can't think of anything more to try.

by

@sparky48 if you feel you can I'd open the watch, disconnect the battery then reconnect it and then try it. They can be resealed with T7000 glue. I've repaired about 5 or 6 fitbits using it.

by

Yes, I have taken apart a couple of Fitbit Ionics and have changed the batteries. I was considering trying that with my Sense as the next step.

by

Show 4 more comments

Add a comment

Add your answer

Ronald Jurgs will be eternally grateful.
View Statistics:

Past 24 Hours: 2

Past 7 Days: 26

Past 30 Days: 89

All Time: 312