Skip to main content

This Lenovo Chromebook released in 2018, has a 32 GB eMMC drive. Equipped with 4GB of ram as well, and has a 1920x1080 (1080p) display.

1 Questions View all

What WiFi dongle should I order?

My internal internet card is broken and I can only connect with a dongle. I'm confused about how to find one that's compatible with my Chromebook.

Answer this question I have this problem too

Is this a good question?

Score 0
2 Comments

Hi Jill,

What brand and model of Chromebook do you have?

by

Sorry to be so long responding -- I've been trying several different dongles, with no luck. I have a Lenovo Chromebook S330 81jw, built on (I believe) Linus Debian 10 (Buster). I would be happy to try to replace the WiFi module if I could get instructions (and can find one to order).

by

Add a comment

3 Answers

Most Helpful Answer

The WiFi modules on most of the Chromebooks I've seen in the past are actually fairly easy to replace, so that might be a consideration if we knew the make and model of yours.

Otherwise, an internet search for "USB WiFi adapter for Chromebook" should give you plenty to work with. A user on Reddit has verified that this one from Amazon works with his Acer Chromebook.

Amazon.com: Wireless WiFi USB Dongle Stick Adapter RT5370 150Mbps for MAG 254 250 255 270 275 IPTV Set-Top Box, Jynxbox, Linkbox, Raspberry Pi, Pc Laptops Desktop, for Win7, Win8, Mac OS, Linux : Electronics

Was this answer helpful?

Score 1

1 Comment:

This one is no longer available but I tried one I thought was close with no luck

by

Add a comment

@Jill Hinckley

Looking at the image on p.44 of the hardware maintenance manual for the laptop, it seems as though the WiFi module is hard mounted on the systemboard and cannot be replaced.

Here's an image of the systemboard that shows it a bit better and I think that it does look hard mounted i.e. non removable. I may be wrong though.

Also there's no mention of it in the parts list for the model. (click on Compatible to see all the parts)

Block Image

(click on the image and when it opens click on the image again to further magnify it)

Are you sure that the WiFi module is faulty?

First check in BIOS to see if the WLAN has been disabled at all. Not sure with your laptop but try pressing the Del key or F2 key a few times, immediately after turning on the laptop. If it boots to the OS then shut it down in the normal manner and try again.

If it is a case of it just not detecting networks to connect to, try using the laptop as close as possible to the WiFi router (<10cm) and check.

If it works then it may be a loose antenna connection.

If it is a software problem I'm afraid that I can't help you as I don't know how Linux works.

If it is a hardware fault and if it is hard mounted then according to a comment in this link a Realtek RTL8812BU dongle (supplier example only) works with Debian OS

Here's the comment:

"WiFi adapter Realtek RTL8812BU is a good choice for Debian OS.

For driver installation a few steps are necessary:

1. Find out, which Kernel is installed (input “uname -a” in terminal). In following example Kernel 5.10 is considered

2. Open web-browser. URL: https://github.com/

3. Search for “RTL8812BU”

4. You will get app. 30 repository results, for example “https://github.com/fastoe/RTL8812BU”

5. For 5.10 kernel, please clone the v5.6.1 branch:

In a terminal you have to use “su” to change your identity to root with password

clone the new branch:

sudo apt update

sudo apt install -y dkms git bc

git clone -b v5.6.1 https://github.com/fastoe/RTL8812BU.git

cd RTL8812BU

make

sudo make install

sudo reboot

Was this answer helpful?

Score 1

6 Comments:

Thank you so much for your extensive efforts to help! It's not signal strength -- WiFi won't turn on. And unfortunately, ithere is apparently no BIOS on chromebooks, nor any kernels (as I discovered after countless hours of trying to install a driver for one of the dongles I ordered). I definitely need plug and play, and apparently a Ralink rather than Realtech chipset. Surprisingly hard to find, but I'll keep searching.

by

@Jill Hinckley Well, unfortunately ChromeOS uses no BIOS or even UEFI; It’s core booted. However; If yours is Debian based (or any Linux distro), then it MUST have a kernel. That is what handles the system. It couldn’t run without a kernel.

by

@Jill Hinckley

Do you know what WiFi chipset is on the motherboard? Is it being detected and just not working or not detected at all?

If not detected then if you don't know what chipset it is, maybe use the hardware manual linked above to gain access to the motherboard and check what info is shown on the chip itself. (and also if it is removable?).

If you know the make (and model) of the chip you may be able to find external dongles from the same maker that might work.

Assuming that it was working when you got the laptop did you update the OS and then the WiFi failed or did it just fail?

It might be worthwhile asking on this website as they deal with Debian OS on various devices.

by

@jayeff Thanks for persisting with this. I found a comment online that gave a dongle chipset that Chrome was going to make available, but when I ordered a dongle with that chipset, it turned out to be "plug and play" for all Linux kernels except Debian, and I couldn't get the driver installation to work. Wrote the manufacturer and got this reply: "Chromebook OS...is a proprietary operating system custom designed for Chromebooks that is rooted in Linux but many of the commands are disabled and packages unavailable. ... Our engineers worked on this for a long time to see if there was any way to 'break' the OS to allow for some type of external USB WiFi functionality but there isn't. So we recommend using on a Linux PC, or Microsoft Windows PC." It's mysterious and frustrating to me because I had a dongle that worked for over a year, just couldn't identify what it was in order to reorder. Maybe I should have started by asking for help with that, but at this point I'm giving up and ordering a new Chromebook.

by

@Jill Hinckley If you want to get information on the wifi dongle that used to work with your system, assuming that now it's not faulty or undetectable, try this: plug it into the chromebook, install (https://helpdeskgeek.com/how-to/how-to-o...) and open the Terminal application, type "lsusb"(without inverted commas), this will output a list of all usb devices attached. Likewise, "lshw -C network" command will show your internal wifi card's vendor and product ID

by

Show 1 more comment

Add a comment

I found this thread when I was searching for a wifi dongle that would work with ChromeOS that I installed on a desktop. I found that this one for the Raspberry Pi works. It's not the most recent tech, but it should get you connected.

https://www.amazon.com/CanaKit-Raspberry...

Was this answer helpful?

Score 0

1 Comment:

Thanks for trying, Aaron, but I had found that thread previously and did order that dongle, but it wouldn't work without installing a driver, which the Chrome OS doesn't allow me to do. Stupid, and frustrating!

by

Add a comment

Add your answer

Jill Hinckley will be eternally grateful.
View Statistics:

Past 24 Hours: 11

Past 7 Days: 59

Past 30 Days: 319

All Time: 1,401