Skip to main content

Released in November 2020, the 13" MacBook Pro features Apple's Arm-based M1 SoC with both an 8-core CPU and 8-core GPU. (Model A2338 / EMC 3578 with two Thunderbolt 3 ports)

63 Questions View all

Liquid damage, No short on Motherboard only chimes nothing else

Hello community,

I am into electronics for approximately 4 years and I already repaired a lot of things. A lot of boards of monitors, tvs and even laptops. So my cousin contacted me, after he spilled cola onto his macbook.

He tried to dry it. Now the macbook tries to startup. A chime sound is played, but nothing happens afterwards. No image on the screen. I controlled if the backlight is not working, but there is no image whatsoever. I tried to plug it onto my monitor. No image also. No backlight of the keyboard. Capslock light not working also. So the laptop is dead.

I opened up the board and inspected it with my multimeter. I found no shorts on the board. Trackpad is also clear and no shorts.

I connected it to the power and tried to measure some Voltages.

There a 3 Coils and I measured everyone of them.

I have a 5V on one Coil. (LC320)

12V on another coil. But only in the small bootup sequence with the chime. (L5230)

But the last one has no voltages at all. (LP800)

The part numbers with (XXX) I have from the BoardView I found on the internet. I can upload the bord schematic too if needed.

So I don't know whats wrong. Unfortunately I can't find any similar problems on other threads. Any ideas?

Thanks in advance

Answered! View the answer I have this problem too

Is this a good question?

Score 0
28 Comments

Sorry I don't have the schematics or boardview drawings for this system so you're one step ahead of me ;-}

I would spend some time over on Louis Rossmann's YouTube Channel - Reviewing these vids

by

I will do in the next days. I know Louis already, but there are no videos for the A2338 model.

by

@harak whats the board number 820-

by

@harak - OK, I see the issue here we are not dealing with the Intel system you have the newer M1/M2 system! Thats what the A2338 is!

I've fixed the model info for you.

Sadly, you won't find the schematics for this series yet! As they haven't fallen off the back of the truck ;-{

by

@danj one guy in the internet made a schematic on his own. I am at work now and will upload it at home. And yes the modell number is A2338.

by

Show 23 more comments

Add a comment

1 Answer

Chosen Solution

Hey guys, after I dropped all my screws from the laptop I searched for them. and to know which screw was missing, I assembled the macbook. afterwards i tried to turn it on and it WORKED. unbelievable. everything is working again. even all the apps are still open. I dont know why it is working now. I cleaned it in the meanwhile again, but did that before too. Perhaps this one was the right one. Nevertheless this topic is solved for me now. Thank you guys for your help.

Was this answer helpful?

Score 1
Add a comment

Add your answer

Selim Karakurt will be eternally grateful.
View Statistics:

Past 24 Hours: 0

Past 7 Days: 0

Past 30 Days: 4

All Time: 166