Skip to main content

Model: C11CD10201 Print/Copy/Scan/Fax Auto Document Feeder Will print on both sides of page Wifi / Inkjet

6 Questions View all

Problem downgrading the firmware of an Epson WF-7840

Good morning everyone,

I've had the bad idea to upgrade the firmware of our Epson WF-7840 (version CD17M6 now).

Now, our non epson cartridges are not recognised anymore.

I've search the web about how to downgrade the firmware. I found the procedure, found how to put the printer in "recovery mode" and, on the Epson website, I found the "Recovery Mode Firmware version CB08LC" for the Epson WF-7840.

But it doesn't work...

First problem, the model of the printer does not appear in the "Epson firmware updater" but it sees that a printer is connected.

Second problem, and it is where it stops, when I launch the Update, it fails with a message on the printer's screen "Data file not found".

I tried with my mac (macbook pro 16" m1 max) and with an older macbook pro from 2009 with the same result. I tried with another USB cable and still no luck.

What am I doing wrong?

Answer this question I have this problem too

Is this a good question?

Score 0
1 Comment

Can someone give visual like pics or something because i have the old file but i get confused when you get to the trick your update part lol... i dont know how to switch them or what it entails.


Add a comment

3 Answers

Most Helpful Answer

In order to fix the problem you need to reinstall FWCH67TL_CD08M4 .This can be done tricking the updater swapping the file during the update .

Go to the temp directory on the C:\Users\Your-Username\AppData\Local\Temp, you should find a Epson directory run the FWCH67TL_CD08M4.exe, now on the temp directory above you will find a directory called Firmware Updater() copy the file FWCH67TL in a safe place (this is the firmware you want).

Close the updater now run FWCH67TL_CD17M6.exe you will find in the Temp directory a new Firmware Updater() directory swap the file FWCH67T to the file you have previously saved continue the update overriding the firmware on the printer.

This should work for any other updated firmware.

Was this answer helpful?

Score 4


Where to find the old firmware files?


@Paul Muir These don't appear to be the files listed in the thread above


Is the FWFWCH67TL the same for the WF7820?


AWESOME. Thank you so much. I have the WF-7840 . I couldnt get it to work at first but ended up opening the the older firmware to install and just copied both the folder that were created in the temp loaction (WZSE1.TMP and Fimware Updater1). then went to install the new update and just pasted both those copied folders into the new folder and replaced the files in the destination. Thanks so much


Show 14 more comments

Add a comment

I had this exact problem. Couldn't figure it out for months. Then, suddenly, I tried one last time, but this time I used the firmware update for another similar model, the EC-C7000. The Firmware version is different. But in my disbelief it worked. I'm still in shock. The CD08M4 version firmware update didn't work for me no matter what I did. But for some reason this other CD17M6 did the trick. Epson is a tricky bastard. I urge you to try it. You can find the version I used on the Epson website here:

Just be sure to let the printer do it's thing. The lights will flicker randomly, and after about two minutes the printer will turn off on its own. Once that happens you can press the power button and viola....

Good luck and godspeed.

Was this answer helpful?

Score 0


So it worked to install the firmware but do all the printer functions work as they should? And could you remind me how to get to the ROM menu? I'm gonna look for that but if you already have the answer... ;)


Ok, the firmware update worked but I still have the same problem : the ink cartridge is not recognised... I tried putting the "CD08M4" file instead of the "CD17M6" also and ended up having the same message : File not found...


I ended up buying the official inks and I hope to be able to go back to cheaper cartridge in the near future. One thing is for sure, I'll never update this F-ing firmware ever again...

&&^& YOU EPSON!!!


It worked for me with the "CD08M4" file. After the update it still showed not recognized. The missing last step for me was to refresh the cartridges. Take them out and reinsert them.


Where did you find the CD08M4 file? I do not see it on either laptop


Show 4 more comments

Add a comment

My printer won’t print after the firm ware update! I have googled and googled and I can’t find any kind of help! Please what can I do to be able to print!?!?

Was this answer helpful?

Score 0
Add a comment

Add your answer

Arnaud Bour will be eternally grateful.
View Statistics:

Past 24 Hours: 8

Past 7 Days: 93

Past 30 Days: 409

All Time: 5,103