Skip to main content

The third generation Pixel released by Google in October 2018.

88 Questions View all

Pixel 3 is charging but not starting up

I recently bought a Pixel 3 on which the seller commented that the buttons had loose connections. When I received and unpacked it the battery was drained to 0% and it did in fact charge but it wouldn't turn on no matter how hard I pressed those buttons.

Normally I would think that it boots up after the battery is charged sufficiently but it does not. The screen stays black, there is no vibration.

I even tried pressing power + volume down but to no avail.

Is there anything I could do or have I been pwned?

Answer this question I have this problem too

Is this a good question?

Score 0

Comments:

I would ask that have you ascertained this issue is not from the power button

by

@josef_tech I think the buttons are fine but the whole thing is just bricked and I have been scammed

by

Add a comment

1 Answer

Most Helpful Answer

If you have a computer

Unplug the cable from the power charger.

Check that your computer is on and connected to a power source.

Connect your phone to your computer's USB port with the cable that came with your phone.

Wait 10–15 minutes.

Disconnect and reconnect the cable from your phone within 10 seconds.

Was this answer helpful?

Score 1

Comments:

Thanks for the suggestion. I tried that but it had no effect whatsoever - I guess it's just bricked.

I found several entries from users who had bricked devices just from some Security Update and Google simply does not care because it's EOL.

https://www.trustedreviews.com/news/pixe...

by

Add a comment

Add your answer

Fred will be eternally grateful.
View Statistics:

Past 24 Hours: 0

Past 7 Days: 0

Past 30 Days: 0

All Time: 24