Skip to main content

Model number: 20R1000RUS, Released in June 2019

12 Questions View all

Ethernet adapter does not work.

My gen 9 x1 Carbon does not have an Ethernet Port, so I bought an USB Type-C to Ethernet adapter. I have used this adapter on 2 different laptops with no problems (Thinkbook gen2) but it does not work on my X1 Carbon. When I go into network settings I can only see WiFi and Bluetooth but no Ethernet. In device manager network tab there is nothing disabled.

I feel like I don’t need a driver for the adapter given the fact that it worked with no driver needed on other laptops. Do I need an Ethernet driver or some sort of other thing to enable Ethernet on my laptop or is my laptop not supporting Ethernet at all?

Update (01/23/2022)

Brand: Omars


Answer this question I have this problem too

Is this a good question?

Score 0

Can you let us know the model number of the adapter you purchased, please?


Does it work if you try plugging in a known working ethernet cable into the adapter with the adapter plugged in? (make sure the other end of the ethernet cable is plugged in to the router/modem/network switch/etc.)


I tested the ethernet cable on another laptop. I also tested the adapter on the other laptop. Both work fine. Only on the ThinkBook it does not work.


Add a comment

1 Answer

Most Helpful Answer

A lot of 3rd party USB-C adapters are kind of spotty —some work better than others. Cheap hubs are especially prone to being inconsistent.

What I usually recommend is if you have a Lenovo is to buy a 1st party one from Lenovo, especially with the X1 Carbon — yours uses a standard adapter, but these were always known to have a dedicated port for it for so many years and they are optimized for the Lenovo adapter. It’s not as cheap as a generic one straight from China, but they usually work better since it’s from the computer vendor. This is the one sold by Lenovo ($18). The X1 Carbon used to have a dedicated port, but they got rid of it; I’m surprised they did because the logic was in the computer and the adapter handled the rest. Yes, it was still an adapter but it worked because it was designed to be part of the system. Some accessories are best purchased from the manufacturer of the computer. Ethernet adapters are one of them, especially if you care about PXE. None of these cheap adapters on Amazon are PXE-capable.

If that doesn’t fix it, check the cable and make sure that’s not the issue. In some cases (like legacy Cat5/5e), the problem is the cable and not the adapter. Cat5 is garbage and best retired. It may resolve with a Cat6/6a or Cat7 cable.

Was this answer helpful?

Score 2
Add a comment

Add your answer

Orhun Coşkun will be eternally grateful.
View Statistics:

Past 24 Hours: 1

Past 7 Days: 13

Past 30 Days: 50

All Time: 3,004