Skip to main content

Released November 2016, the PS4 Pro features upgraded hardware for 4K gaming and improved PSVR performance.

344 Questions View all

My PS4 pro wont turn on, power button not working, but eject botton do

I didnt turn on my ps4 pro for 2 weeks, today when i turned it on it gave up on me.

the behaviour is as follows,

when I switch on power from wall socket and try turn it on form the 1st time it gave me 3 beeps and turned off, when i tried to tun it on it gave a beep and went into safe mode. which ever option i try in safe mode it boots back to safe mode(loop). Tried update with pendrive and also full reinstall as well.
i read somewhere that power input issues, so I tried unplugging and put the adaptor in different socket. the things went further bad.
now i cant turn on my ps4 pro at all, power button stopped responding, i can’t turn on using my controller (tried both wired and wireless).
I was using a ssd, so I tried replacing with original HDD as well. same behaviour.

I thought my ps is dead, then suddenly i clicked on eject button and it gave 2 beeps saying no disk in bay. so i tried inserting a disk, and my ps4 pro started to boot and again it went into safe mode loop, like earlier.
So I am not sure what is the problem is, is it anything i can fix or hardware issue.
Any helps on how to proceed further is highly appreciated .

Answer this question I have this problem too

Is this a good question?

Score 1
Add a comment

1 Answer

Have you tried a different HDMI cable? I had a base ps4 that would beep and shut off, turned out to be a bad HDMI cable.

When you tried to turn it on with the controller wired did you just press the ps button or did you hold it? Try holding instead of just tapping.

You mentioned update via pen drive and full reinstall. You are aware that there are two different files? The small one is for regular updating, and a different much larger one for os reinstall.

When it boots into safe mode, select Restore Default Settings. Had another unit failing to boot after a power out, resetting the settings put it into 480p which allowed me to boot into the home screen and set the resolution back.

If it safe mode boot loops still, try Rebuild Database.

The last “simple” thing I can think of is try swapping in a known good power supply.

Definitely odd and interesting. Good luck!

Was this answer helpful?

Score 0


Firstly sorry for delayed response, Thanks for responding,

Yes i tried different HDMI cable

I am using PS from 2.5 years, so i tried clicking ps button, holding ps button, while usb plugged and in bluetooth mode. also i am not able to turn on/go safe mode with power button.

yes i tried update with pendrive and i am aware update and reinstall have diff sized files (update was around 480 mb and reinstall was around 1GB)

when i try reinstall, system is copying the file, then a loading bar saying preparing for install, then boom, once it reaches 100% PS restarts and go into safe mode,

Same with change resolution/rebuild database, restart etc any option i try

the physical power button stopped working when i chnaged the power supply port.

I havent tried changing the power supply cable.

If you know anything else pls suggest


Hi, I am facing exactly the same issue on on 5yo Ps4pro. It's stuck on an infinite safe mode loop. Power button isn't working and the only way I can get it to respond is by feeding it with a disk.. greedy o'l console.. I have tried almost everything related to software, rebuilding database, Installing software through USB, lan cable.. Heck I even wiped the HDD clean by connecting it to my PC. But to no avail.. The only thing remaining is a total teardown. Resetting CMOS battery does seem to help some people. If you do come up with a solution, it would be highly appreciated 👍🏻


Add a comment

Add your answer

Vamsi svk will be eternally grateful.
View Statistics:

Past 24 Hours: 3

Past 7 Days: 15

Past 30 Days: 112

All Time: 895