Skip to main content

Model A1312 / Mid 2011 / 2.7 & 3.1 GHz Core i5 or 3.4 GHz Core i7 Processor, ID iMac12,2

691 Questions View all

Not turning on. LED 1 light stays on after 'new' power supply & logic

I just hit a dead end.

Someone gave me a broken A1312 so I thought I could fix it.

At first, the diagnostic LED 1 stayed on. But it wouldn’t turn (No LED 2, 3, 4)on when I press power button. I took a step and try to check power button by wiring two pins together. Nothing. So it shouldn’t be the power button issue.

Next I changed power supply; bought used one from reputable seller. Same issue. LED 1 stayed on, but wouldn’t start after pressing power button. (No LED 2, 3, 4)

Next I changed the logic board; again, bought used one from online reputable seller. SAME THING! LED 1 stays on, but not turning on when pressing power button. (No LED 2, 3, 4)

Is there another step of trouble shoot for LED 1 is on but not turning on? FIY, I always plugged into the wall directly. Even tried different 3-prong cables.

Please help. Now I’m in ~$150 with parts with this computer :(

Answer this question I have this problem too

Is this a good question?

Score 0
Add a comment

1 Answer

Most Helpful Answer

My first bet would be that you got a bad power supply from your reseller. This has happened to me several times. You can also end up with a partially functioning PSU. But the fact that you never got the #2 LED to light is the telltale.

These part numbers will work for you 661-5310, 661-5468, 661-5972.

Was this answer helpful?

Score 2

Comments:

Here's one with a god warranty: iFixit iMac Intel 27" EMC 2309, 2374, 2390 or 2429 Power Supply

by

Ok, I just spent 3 HOURS trouble shooting. I borrowed my friend's 2009 iMac 27" to test different parts, since 2009 iMac and 2011 iMac shares same power supply.

The power supply WORKED. Even the original power supply which I thought it was broken, worked on my friend's iMac! I even tested the power button by connecting the connectors so that my iMac's power button behind the screen can turn on my friend's iMac computer, which it did.

But my friend's power supply (which I KNOW it works) wouldn't turn on my computer. Same LED 1, but no other LED would turn on, nor the computer would turn on.

As I was going through more troubleshooting, I wondered, can Power DC cable be faulty?

I tried to swap my friend's 2009 iMac DC cable harness to my 2011 iMac but it wouldn't give me even LED 1. Samething, my DC cable wouldn't turn on my friend's "perfectly working iMac." I guess those two DC cable harness are not interchangeable.

So... my next task is buy a new power DC cable for my 2011 iMac and try.

Can this be even possible? Can Power DC cable go bad? And it would give LED 1 but would NOT turn on the power?

by

Add a comment

Add your answer

Shawn Kay will be eternally grateful.
View Statistics:

Past 24 Hours: 0

Past 7 Days: 0

Past 30 Days: 0

All Time: 48