Skip to main content

Fix Your Stuff

Right to Repair

Store

A1708/EMC 3164 — Released June 2017, this entry-level MacBook Pro retains its traditional function keys (as opposed to the OLED Touch Bar).

366 Questions View all

A1708 MBP does not always reboot after installing a custom ssd

Hey guys!

A few days ago I swapped the factory-installed 128GB SSD for a Sabrent 1TB Rocket NVMe PCIe M.2 2242 SSD on my 2017 MacBook Pro without a touchbar. The installation itself went without any problems and the new SSD was recognized immediately.

With the help of an external recovery stick, I first formatted the new SSD as APFS and in the GUID partition scheme and then installed Big Sur. During the installation where the MacBook had to restart several times, I noticed that the MacBook shuts down, but then I had to restart it manually because it didn't do this by itself. Big Sur is now fully installed and I have all my data back via a Time Machine backup, but it still seems to have a problem when restarting:

It switches off, takes about 15 seconds, then switches on again and then shows the folder symbol with the question mark - it does not seem to recognize the hard drive.

If I then manually shut it down again and then boot into recovery mode with cmd + R (sometimes it is the Internet recovery and sometimes the system-internal recovery, booting into recovery mode from usb drive works as well) and then shutdown the macbook in this mode and then start it again, the macbook booted without exception and without any problems always normal to MacOS.

After this procedure when I am in the operating system, the following appears in the error report:

*** MCA Error Report *** CPU Machine Check Architecture Error Dump (CPU: Intel (R) Core (TM) i5-7360U CPU @ 2.30GHz, CPUID: 0x806E9) CATERR detected! No MCA data found.

Strangely, if I shut down the macbook normally and then turn it on again, this problem does not occur, so that the mac then boots normally into MacOS.

Things I've already tried to solve the problem:

  • SSD completely erased again, reformatted, installed the factory-installed MacOS Mojave and updated from there up to BigSur
  • PRAM / NVRAM & SMC reset
  • deactivated FileVault and restarted
  • started in safe and verbose mode
  • rapaired the ssd in disk utility tool several times
  • with 'bless -mount "/ Volumes / Macintosh HD" -setBoot' set the hard disk again as the start volume and restarted, here I have deactivated SIP beforehand, because this command otherwise failed with "Could not set boot device property: 0xe00002bc"
  • tested MacBook with apple diagnosis (held D key at startup), ended with ADP000 - No issues found.
  • adjusted power management settings with pmset command to counteract the rapid discharge of the battery

All of these attempts were unfortunately unsuccessfull.

I'm really desperate. Does anyone know a solution?

Answer this question I have this problem too

Is this a good question?

Score 0

Comments:

My adapter is “NFHK N-1708A”, name and detail color gold

by

I have the same problem with you, did you sort it out in any way?

by

No, I sadly didn’t solve the problem. :(

by

I ordered another SSD Sabrent with his adapter, I'll tell you if I solved the problem in a few days

by

Hi

I have same problem with Sabrent 2Tb ssd and Sintech adaptor, I tried with another adaptor but didn't solve the problem. wondering to order another Sabrent ssd ... waiting for your report.

by

Show 8 more comments

Add a comment

8 Answers

Most Helpful Answer

Sadly, your SSD replacement is giving you problems ;-{

Time for a replacement of either the carrier or the M.2 SSD its self or both!

While its more expesive (sadly) you might want to get a real Apple SSD Custom Apple 1 TB SSD

Was this answer helpful?

Score 3
Add a comment

Try physically removing the component, check for dust / hair on the contacts. Then re-install. I've had a similar problem with a video card installation on an m17x. One of my wife's hairs made it into the contact bar. Sometimes the simplest solutions are the best. Also, make sure you are grounded! When the case is open, it is no longer a faraday cage, and several thousand volts of static electricity can be transferred to the motherboard without you ever knowing, especially in low humidity conditions.

Was this answer helpful?

Score 2
Add a comment

I have the same problem. Same Sabrent Drive and same Amazon adapter.

I had the folder icon at startup when installing macOS through internet recovery.

No I don’t have the folder icon at startup after installing from usb drive.

I still have the restarting problem though. It does not seem to be better at a certain version of macOS. I tried High Sierra, Catalina and Big Sur. Same problem.

But when I try to restart it still gives me the exact same error message as above.

I found a German forum where they seem to have a similar problem. Their suggestion is to unplug from power before restart if I understand correctly. It didn’t work for me though.

https://www.macuser.de/threads/macbook-p...

I hope someone will find a workaround!

Was this answer helpful?

Score 2
Add a comment

***UPDATE***

If i install catalina i have no issues but as soon as i update to big sur 11.2 and 11.2.1 thats when i get the issues

Was this answer helpful?

Score 1

Comments:

Interestingly, maybe it's an OS problem then. What idea for the resolution?

by

Is there an alternative way to install the latest OS cleanly? Maybe with disk partitioning?

by

this is what im thinking because when i install catalina i have no issues

the errors seem to happen when i upgrade to big sur 11.2 or 11.2.1

iv also put the new ssd in an enclosure plugged it into the mac and wipped the drive reinstalled catalina upgraded to big sir restored from one of my time machine back ups and it works perfectly

the issue i keep getting is when i intall the the new ssd into the mac

by

Today Apple has released the new OS 11.2.2, try to check now who knows they have solved

by

Add a comment

I’ve had issues with my iMac restarting while not using it and this “CATERR detected! No MCA data found” has been occurring a lot lately. I am on Big Sur 11.2.1. I have a 3rd party SSD (Samsung) and I have a Sabrent Thunderbolt 3 dock, and a thunderbolt sound card (UAD).

I am keeping the sound card off for now, but it’s interesting the name Sabrent is something we have in common.

Was this answer helpful?

Score 0

Comments:

I also have this problem ...exactly as described Sabrent 1TB SSD in A1708 MBP. :(

by

Add a comment

UPDATE:

I returned both of my Sabrent SSD, bought a Samsung 970 EVO Plus, and the problem is gone. Unfortunately the Samsung does not have the 2242 version so I opted for the 2280 (I hooked it up with electrical tape)

I reported the problem to Sabrent after contacting Apple support, according to Apple it is an SSD compatibility problem with BigSur.

Here's how Sabrent answered me:

““Thank you for contacting Sabrent support.

My apologies for the inconvenience that this has been causing you. Unfortunately, we do not have a firmware update for this incompatibility issue. I recommend you stick to the Catalina version while Apple releases, new features and updates while taking into account their customer feedback””

Was this answer helpful?

Score 0
Add a comment

my “restart” problem happens on Mojave and Catalina both OS. i have not tried BigSur.

i had sabrent 2Tb and sintech adaptor ( and another no brand adaptor ) on A1708, 2017 MBP function key.

i sent back the ssd and going to get refund for adaptor.

i found couple of SSD ( looked like combined 2240 ssd + adaptor ) with working guaranty for A1708 on eBay US but up to 1TB, since i need 2TB, I ‘m using external USB case with my old 2012 MBP 2.5’SSD (mojave ), it takes little longer to start up but no issue.

right now i ‘m not travelling , so this external system is ok but for the future when the pandemic goes down i will travel a lots like before and i will need decent internal system, i ‘m still looking for solutions.

i don’t know who is making 2240 ssd 2TB beside sabrent. and all adaptors looked same on amazon and eBay.

Was this answer helpful?

Score 0

Comments:

Have you tried looking for KingSpecs?

by

i don't find KingSpec ssd fits into A1708 in my amazon (JP), do you think it would work ?

by

i have spoke to one off the king spec sellers on ebay and he said hes having issues with big sur

by

Add a comment

I have the same problem, and I have not found any valid solution.

The problems I usually have and the solution I have used are:

1. When you get an update and the computer needs to reboot, it doesn't reboot automatically. I have to have the power cord disconnected and hit it manually when it won't boot.

2. When the computer is connected to the power and I open it, it usually does not start and the folder icon appears with the question mark. The solution is to hold the power button, turn it off and turn it on by disconnecting the power cord.

Was this answer helpful?

Score 0

Comments:

Yes same problem here I'm using Sabrent 1TB ssd in Macbook Pro A1708 and it will restart after a few minutes but get the error message that it was shut down due to a problem. If you shut down and restart it works fine. I know it's the ssd because I have a Samsung no-brand 500GB 2242 and it works fine but the read write speeds are really slow compared to both the original 256 GB drive and Sabrent drive. I sure hope someone figures out an answer to this problem. I don't want to go back to the old Mac ssd.

by

Add a comment

Add your answer

Lukas will be eternally grateful.
View Statistics:

Past 24 Hours: 9

Past 7 Days: 49

Past 30 Days: 209

All Time: 924