Im not getting prompt with "network unlock key"

So I just finished fixing a galaxy s10 and the first thing I did was go to my carrier and ask them to put my number in it, they told me that everything got connected but that the phone wasn’t able to call, text, or get network data. even though it said that it was connected to the network, after not getting anywhere with it I decided to just get my old phone back and later learned that the phone might have been locked to another carrier I tried asking that carrier to unlock my phone but they said that in order to do so they will need me to change over to them and be with them for 6 months. I don’t want to do that and decided to get a third-party unlocking company that could unlock my phone but now my phone doesn’t display the “network unlock key” even after doing the dial and change sim method. the phone was originally from consumer cellular I tried to change it to metro and after that change anytime I tried calling it said “call not sent” so the only thing I have left is to unlock it but since I don’t get the network to unlock screen IDK if getting a key from a third party would work. does anyone have any advise?

Answer this question I have this problem too

Is this a good question?

Score 0
Add a comment