SSD is not recognized

Hello All,

I have been searching the web for a fix for my Late 2012 MacBook Pro with Retina and can’t seem to find any answers. I am hoping someone else has had the same or similar issue and would be willing to help me. Here’s my backstory:

I have a Late 2012 MacBook Pro w/Retina and a 128GB proprietary SSD. I wanted to install Windows 10 via Bootcamp but I needed a bigger hard drive. So I went with the less expensive route and purchased this SSD with this adapter instead of an owc drive.

Asenno 512GB ssd -

Sintech M.2 to sata adapter -

At first I installed the new drive and formatted it correctly. I then installed Snow Leopard, to El Capitan, to Catalina (not knowing about command+option+R...).

Once I got Catalina installed I noticed a battery issue saying “no battery detected”. I didn’t think much of it and thought an update would fix it but it didn’t. I proceeded with the Bootcamp install and once I got Windows on my Mac I realized that the battery issue remained. This was a nuisance because my Mac would turn off if the power cable was disconnected.

I thought that removing the battery connector and SSD, then putting it back would solve the issue but that’s when my main issue arose. Now my MacBook will not recognize the new SSD or the Original one in Disk Utility or using “diskutil list” in Terminal.

I thought the issue now was with the SSD Tray that the Late 2012 models come with so I ordered one from eBay and when it got here I tried it with the old and new drive but still the same issue with it not showing up. I also see that there is a red power light on the new Asenno SSD so I can see the Tray is working.

It’s just that the computer doesn’t see the drive. I have already tried SMC, NVRAM/PRAM resets with no luck. I don’t believe it to be a logic board issue because the computer boots fine from an external drive but not with an internal one but I could be wrong and it is a logic board issue.

I was also reading that installing Windows 10 via Bootcamp could have messed with the Firmware? EFI?

Any help would be greatly appreciated!

Answer this question I have this problem too

Is this a good question?

Score 0
Add a comment