Touch bar not responsive to touch and now sleep broken

Hi. can you help me? I recently replaced my Touch Bar (it was faulty). everything went well, except that now my system no dot wake from sleep. I did this test and the display went out, but it will not wake again.

If I connect an external display it briefly displays the ui on that, but goes to sleep again.

Running `ioreg -r -k AppleClamshellState | grep State` over ssh results in it saying "AppleClamshellState" = Yes even with the display open.

Where should I look for troubleshooting this?

—-

Let me explain what happened to this computer to give a better understanding.

About a year ago I felt that the usb-c ports of my MBP2016 where a little loose.

I took to an Apple Store here in Brazil, but the genius tested with their cables on the store and said it was ok. A few months lather I got annoyed again with the ports, most because I was working from home because of the pandemic and started to use more peripherals on my MBP.

Then, in April, I opened the computer and discover that they were in fact loose (https://youtu.be/pvbQ-1pJJrg) and when I fixed I broke the Touch Bar connector.

Block Image

Block Image

The Touch Bar continued to show items but was not responding to touches (https://youtu.be/HGC5OYdgk-Q).

I bought a new Touch Bar from AliExpres and then opened the MBP to fix it again…

Everything worked fine as far as I could see, but after I closed it all up and went to make some checks and test if it was good I noticed that I was not coming back from sleep.

Further inspection using `ioreg -r -k AppleClamshellState -d4 | grep State` tells me that when I close the lid and then open this “flag” does not change to “No” anymore making the MBP not identifying that the lid is open and going back to sleep.

I discover that if I disable sleep with `pmset -a disable sleep 1` I can continue to use the Mac after I open the lid, but only on a external monitor… the internal keeps its backlight off but I can see that the UI is there.

I hope I made a little more sense this time to help identify the problem and if I can fix it.

I already tried:

  • Clear SMC
  • Clear NVRAM
  • boot in secure mode

Other photos form the computer. It was a little dusty, but I cleaned up.

Block Image

Block Image

Edit: Typo, Include photos and better explain what happened.

Answer this question I have this problem too

Is this a good question?

Score 0

Comments:

Clearly your logic board also got damaged from the liquid spill. Unless you have the deeper skills and tools to work with SMT devices. You'll need access to the schematics and boardview drawings.

by

Sorry, it was not salty, but faulty.... autocorrect changed... it does not have liquid damage, it was the ribbon cable that got damaged by me in other occasion... sorry for the confusion...

by

@fcrespo82 - Can you post a picture or two so we can see the damage Adding images to an existing question

by

@danj - I edited the post with photos and explaining a little better what happened. Thanks!

by

Add a comment