1.83, 2, or 2.16 GHz Core Duo processor

339 Questions View all

Swapped lower enclosure now mac wont boot, fans twitch, help!

Hi,

I dis assembled and swapped the lower aluminum enclosure on my a1150 MacBook Pro. I followed the instructions meticulously and now upon reassembly the computer will not turn on.

the battery takes a charge and displays full, i have tried with and without power adapter.

When I press the power button, the two fans attempt to spin and appear to twitch. Then nothing, I have tried removing the hard drive with the same results.

Please help!

Thanks,

ANDY

Answered! View the answer I have this problem too

Is this a good question?

Score 2
Add a comment
Black Friday
Broken doesn't stand a chance.

2 Answers

Chosen Solution

Reset the RAM and make sure it is all the way in. Try it first with just one module.

Was this answer helpful?

Score 1

Comments:

thanks, tried this. No change. i still get the two fans trying to spin and no other signs of life from the mac. I carefully dis assembly the computer again and re assembled it to double check all connections with no change in results. i don't know what else to try...

by

Tell me about why you replaced the lower enclosure. Was it working before you started?

by

computer worked fine before lower enclosure swap, except for a dead superdrive. my intent was to replace the superdrive and while i was at it swap the enclosure as it was dented in the superdrive corner - likely the cause for superdrive failure.

Thanks for your responses so far, I am not sure how to proceed. I would love to be able to tell if the motherboard is dead.

Thanks,

ANDY

by

Tell me about the replacement drive. Are the part numbers the same? Where did you get the part?

by

The replacement superdrive part number matched exactly. I bought it off ebay - seller guaranteed it would work. i did attempt to turn on the computer with the hard drive and the optical drive disconnected and removed from the MacBook Pro. I got the same results - when i press the power button the only result is that both fans try to spin as long as i have my finger on the power button, but do not fully rotate - they kind of stutter.

by

Show 3 more comments

Add a comment

Hi,

It seems this same case [URL|Fans bumping not spinning not powering on]

Did you find a solutions to your case?

Was this answer helpful?

Score 0

Comments:

it looks like he did. it was faulty drive. i still would try different ribbon cable, as that is commonly cause for the same problem.

by

Would the MB start without the HHD Ribbon cable (without the HDD connected)?

by

Yes

by

Add a comment

Add your answer

ednedesigns will be eternally grateful.
View Statistics:

Past 24 Hours: 0

Past 7 Days: 1

Past 30 Days: 4

All Time: 1,897