Skip to main content

The HP Elitebook x360 1030 G3 is a 13.3" two-in-one laptop released in 2018. This model name can be found on the underside of the laptop in "Project Name."

10 Questions View all

USB devices are not working on my HP Laptop

Alright, so here’s what I’ve got

- Windows 10 Home

- Hp x360 1020 G2 (This wasn’t on the device list, so i chose the most similar type)

- Any kind of mouse

- J.Burrows Type-C USB 3.0 Hub 4 Port

- Just a quick thing, this model of computer has no USB ports so the hub is required

My issue is that whenever I plug any form of mouse into my laptop, nothing happens. The red light on the mouse will either just stay on, or only light up for a second. When I try this mouse on other computers, it will work perfectly with no issues at all. Before you say “Well then it’s obviously your USB hub”, its not. A friend let me try the hub on their exact same model computer, and it worked. In device manager, instead of showing the mouse it says things like “Unknown USB Device (Port Reset Failed)”. If anyone could help I would greatly appreciate it.

Answered! View the answer I have this problem too

Is this a good question?

Score 0
3 Comments

Hi,

Try "uninstalling" the USB controller in Device Manager > Universal Serial Bus controllers > right click on the controller > Uninstall and then restart the laptop so Windows can reinstall the controller and then check if it now works.

Presumably you meant that the laptop has no USB 2.0/3.0 ports and not that there are no USB ports at all as it has a USB-C ;-)

by

Yes, it only has a USB-C port and the hub is required. I have already tried uninstalling the driver but this seemed to do nothing, and I still have the same issue.

by

Hi,were you able to sort this issue.i also have the same problem

by

Add a comment

2 Answers

Chosen Solution

Hi,

Try the following:

Here’s a link that describes how to update the drivers for the Generic USB hub drivers. (see method 2)

Here are the drivers for the laptop. Scroll down and click on Driver -Controller (1). It is the driver for the Intel Thunderbolt 3 secure connect for 2018 (last update 14/04/2020) I think that this is the driver. You could always check if it is already this version 17.4.78.500 Rev.B

Was this answer helpful?

Score 1
Add a comment

Okey, I own this Device and I encountered this issue after BIOS Updates. the power cuts form the ports nor USB or Type-c Port will work.

Fix: the first method was downloading an older BIOS version and update it to that. it has worked. but... after few weeks the problem appeared again.

The Second method was to unplug the laptop from the power or any other cables. power off the computer then hold the Power button for more than 30-60 seconds. then press the power button one time and congrats the ports are usually working again.

Hope this works for you..

Was this answer helpful?

Score 0
Add a comment

Add your answer

QualityPotato 99 will be eternally grateful.
View Statistics:

Past 24 Hours: 2

Past 7 Days: 10

Past 30 Days: 59

All Time: 4,975