No bootable device found after laptop used in journey

I had a strange issue. I used my laptop while travelling and when reached home, I opened it after few days and saw there was “No bootable device - - insert boot disk and press any key" error. Story is interesting. My laptop has an SSD inside and a hard disk in place of dvd socket using a katty. Both hard disks have installed windows 10 both of which are working and bootable in normal conditions.

Well when I saw this error, I used every online help to change bios settings, removed hard disks and re-inserted, took it to every technician in town but it gave same error. While I was thinking to format and try to reinstall windows, as hard disks were detected as per bios, I went to my final technician, gave him the laptop, he took it, held it high in both hands for around 15 seconds while I was not looking what he did, he said, “Your laptop is working now.” What……… I could only say that.

Time passed..

I never opened my laptop during journey after that except yesterday, and look what has happened: it is giving that same error again with same grace. No bios settings working.

Does anybody has any idea about what keys that person may have pressed to get the laptop working? Or did he do something else? Or was it just nothing and laptop got working on itself? I am far away from that technician so if anybody here can help, it will be great. Thanks

Answer this question I have this problem too

Is this a good question?

Score 0

Comments:

I disassembled the laptop and saw that one hard disk was loose. I fixed it, cleaned the dust with tooth brush and reassembled it back. Now it won't turn on on battery or on power. No led lights, no signs of life.

by

Add a comment