Model A1136 / 30, 60, or 80 GB hard drive / black or white plastic front

801 Questions View all

all functions except audio playback for mp3 and m4a files

I am working on the Ipod Video 5th gen. I have restored, and given the way it is behaving, I purchased another hard drive and replaced it. Same function. Weirdly on both, if I put the Ipod into Disk mode, I can play the files directly off the Ipod from windows by browsing to the files, so the hard drive seems fine. I've updated my Itunes to 10.4.1, and done a full restore on the Ipod with no difference. The touch wheel makes sounds if set to do so. The games can be played. I've gone through the diagnostic mode, and everything comes out ok from what I've been able to tell. When you browse the Ipod to the file, it comes up, but the scroll bar at the bottom never moves from zero. You can select and "scroll" through the song, but no sound comes out, and when you stop the bar doesn't advance. I checked and the Toshiba drive has the Toshiba hard drive ribbon. I formatted the drive to fat32 with windows, and restored the ipod again to no difference. When I replaced the screen I peeled the tape off the outside of the metal frame, but it is behaving as it did before I did this, so I think that is a false trail. I even thought perhaps it was some apple software thing, so loaded Rock Box onto it, and it behaves the same. Everything works except playing the audio files. Help?

Answered! View the answer I have this problem too

Is this a good question?

Score 0
Add a comment

2 Answers

Chosen Solution

The only thing I can think of right now, would be to try and change the HDD cable as well. If your hard drive functions as a disk it "SHOULD" not be a problem with the drive, but the interface between the iPod and iTunes. One of the things I do know from experience is, that the HDD in the 5th gen can behave goofy. Also, double check on your audio jack/hold switch....

Was this answer helpful?

Score 1

Comments:

Thanks, that was my thought as well. I've got a 40 pin zif ribbon ordered... I wonder if this "goofyness" is why it is almost the only Ipod with the 40 pin zif drive.. Hopefully this works! I'll check back in a week or two when the new ribbon comes in from China.

by

sounds good and let us know how it is going. Like to know about this one myself...:-)

by

Add a comment

well, I received the new 40 pin zif ipod ribbon. I switched the ribbon, using the 1st drive. The ipod showed no change as to the drive showing the data, I could move among the files, but when "playing" the play would not advance. I swapped to the new drive, which I had formatted with fat32 in windows, then did a full restore on the ipod. Loaded music, and had the same problem. All looked like it was there. I tried mounting the ipod in Drive mode, and could play the music files from the ipod itself, but when using the ipod on its own, it would not play. I swapped to a Compact flash adapter, in case both hard drives I had were dysfunctional... same thing. Seems to me the problem must be on the board itself. I think it may be time to cut losses...

Was this answer helpful?

Score 0

Comments:

does your clickwheel do what it is supposed to and is your hold switch working okay? Check it in diagnostic mode

by

Add a comment

Add your answer

Jesse Waldron will be eternally grateful.
View Statistics:

Past 24 Hours: 0

Past 7 Days: 0

Past 30 Days: 1

All Time: 455