Skip to main content

Released in 2015, the ASUS X540s is a 15.6-inch laptop that comes with an onboard graphics processing system capable of outputting HDMI video.

18 Questions View all

Touchpad Unrecognizable by Laptop After Clean Install

Hi all,


My mom's laptop (Asus x540s) had a bsod that I worked out to be a dead/corrupted hard drive. I installed a new SSD to replace the HDD and reinstalled Win10, but from the get go in setup, I had no access to the touchpad.


The touchpad doesn't appear in Device Manager, the only thing there is an I2C HID Device that has a warning on saying "The device cannot start. Code 10. A request for the HID descriptor failed".


I've done a lot of research and asked around but no solution has been found yet. So far I have: reinstalled Windows multiple times; replaced the touchpad and cable with new ones; installed every driver, software, chipset, and BIOS on the ASUS support page and in different orders as well as older versions of the major ones; installed generic touchpad drivers for all major manufacturers (later figured out it's made by ELAN), then tried multiple ELAN drivers; downloaded a USB run Linux distro to try to get access to the touchpad sans-Windows; enabled and disabled the touchpad setting in the BIOS; uninstalling the I2C HID Driver; used the keyboard control to turn the touchpad on/off; and other random suggestions from around the web.


Any help you can provide would be greatly appreciated, thanks!


Answer this question I have this problem too

Is this a good question?

Score 0
Add a comment

2 Answers

The only way to get to your HDD is by removing the top layer (keyboard + touchpad), just make sure that you put back correctly the touchpad wires, even if it looks good but still not work retry again because the problem is there, make sure not to break it and good luck :).

Was this answer helpful?

Score 0

2 Comments:

Thanks - I did try the cable multiple times to make sure it was fitting right, then also tested the replacement touchpad’s cable. No luck.

by

As far as what I noticed it's a Hardware issue since the Touchpad don't work while you're in BIOS settings or W10 installation, so I don't think any software can help you to fix it, use gently a toothbrush to clean the pins on both sides, if you have an electronic cleaner spray use it too.

by

Add a comment

Hi,

You may have tried this already so apologies if you have but try installing the latest Asus Smart Gesture and ATK Package drivers from here.

You may have to uninstall the old drivers first (Control Panel > Programs and Features)

Be sure to install the ATK Package drivers before installing the Smart Gesture drivers. See the Note: near the top of the webpage regarding how to install the drivers.

Was this answer helpful?

Score 0
Add a comment

Add your answer

Josh Ragusa will be eternally grateful.
View Statistics:

Past 24 Hours: 0

Past 7 Days: 0

Past 30 Days: 7

All Time: 1,188