Skip to main content

Repair and disassembly guides for LG K series smartphones.

227 Questions View all

Why will my phone only charge if plugged in while powered off?

The phone is an LG K40

Model number: LM-X420MM Rev. 1.0

Android version: 9 with April 1, 2020 patch.

Kernel: 4.9.112

Build: PKQ1.190302.001

Configuration version: 2.380001

Software version: X420MM10P


The phone just randomly started having this really odd charging issue where it will only charge under certain conditions.


  • Powered off, and plugged in.
  • Powered off, plugged in, THEN powered on.
  • Powered on, plugged in, THEN RESTARTED.


  • Powered on, plugged in and NOT restarted.

Things I have tested & the results;

  • Powered on; plugged into PC | no change not detected
  • Powered on; plugged into PC; AND RESTARTED | It charged but was NOT detected by pc
  • I attempted to change the USB connection type. It was greyed out as if the phone couldn't tell it was plugged into a PC vs a wall outlet
    • This made me think it's it unable to tell if it is plugged into a PC so I tried the next thing
  • I plugged into PC; restarted; tried to turn on usb tethering. | This too was greyed out.
    • I attempted this on two different PC's with the same result. The phone is not detected by either PC.


I have since decided that it is one of three different things; the battery, the charger port, or a software issue. I almost want to even eliminate the battery as an issue since it holds a charge for a while and doesn't appear to have an issue. So it's pretty much down to a charging port issue I'd assume... Which I am okay with replacing if needed because I really love this phone, even though I am a HUGE Moto fan. I was looking for a repair guide and noticed this phone isn't even listed on this website. That's a first for me.

So, if anyone has any advice, troubleshooting, or words of wisdom for me and my odd charging issue I am all ears (or eyes) :P and appreciative.



Answer this question I have this problem too

Is this a good question?

Score 0
Add a comment

1 Answer

Hi @dvcastell2 ,

Visually inspect the micro USB charge port with a strong light and a magnifying glass to check that there is no lint or other debris lodged in the port enclosure that may prevent a good electrical connection. Also check that all the pins are straight and parallel with each other and not bent etc.

If there is any debris, do not use a metal pin or probe to try and get it out as you may damage the pins or cause electrical problems in the phone, use a vacuum cleaner instead to try and suck it out. if it won't dislodge use a vacuum cleaner to try and suck it out. it it won’t dislodge use a sharpen wooden toothpick to gently prise it out.

If the port seems clear try the following:

Plug in the micro USB charger cord into the phone but do not connect the other end of the cord to anything. Firmly grab hold of the phone in one hand and then hold the inserted USB plug between the thumb and forefinger of the other hand and gently, stress gently try to move the USB plug from side to side and up and down to detect any movement at all in the phone’s USB connector port. If there is then it may be loose from the daughter board module that it is mounted on. Here’s a video that may help. At 9:42 minutes into the video there is a good view of the USB port on the board

Was this answer helpful?

Score 0
Add a comment

Add your answer

Dougie will be eternally grateful.
View Statistics:

Past 24 Hours: 0

Past 7 Days: 0

Past 30 Days: 4

All Time: 169