Skip to main content

Fix Your Stuff

Right to Repair

Store

2.26 or 2.4 GHz / White plastic unibody enclosure

752 Questions View all

white screen, chime, no logo nor spinner, caps lock works

The pimary operation I think I’ve did was to reapplying thermal paste, as I was doing that, I cleaned the trackpad and removed a CD that was stuck in the optical drive (it was not reading anyway). So, I’ve pretty much disassembled the whole thing.

Now, when I power on the device the following happens:

  1. I hear the chime
  2. LCD powers up, completely white with backlight on.
  3. No apple logo or anyhting.
  4. After a while screen gets a tiny bit dimmer, almost like power saving feature but the it does this even when the power is plugged.

Caps lock works.

I’ve tried reseating LCD cable to the logic board several times.

I’ve also read chime, white screen, no logo or spinner

  • Safe boot didn’t work.
  • Unplugged hard drive and optical drive, plugged in a Mojave install usb stick and it still didn’t work.
  • I don’t have a minidisplay port adapter so I can’t test an external monitor just yet.
  • Seconds after power up I can feel heatsink is getting quite hot, touchable hot but barely touchable. Is that normal for a Core 2 Duo?

Any ideas what might have gone wrong?

Answer this question I have this problem too

Is this a good question?

Score 0
Add a comment

1 Answer

I have an A1342 with similar problems to yours. I’m suspecting it’s the same issue as mine - a fault with the logic board.

I tried using an external display on that, absolutely nothing. The computer also gets hot but after about 5 minutes.

I should also mention Mojave is officially unsupported on this MacBook generation. Maximum they can support is High Sierra 10.13. You can get it running with a patcher but I don’t advise doing that.

Was this answer helpful?

Score 0
Add a comment

Add your answer

Engin Aydogan will be eternally grateful.
View Statistics:

Past 24 Hours: 0

Past 7 Days: 0

Past 30 Days: 0

All Time: 9