Skip to main content

Fix Your Stuff

Right to Repair

Store

Repair guides and support for your Sanyo TV.

338 Questions View all

Red light on but not turning on

I have a sanyo flat screen tv. FW24E05T. It's in good condition atleast 3 years old never had any problems, but has been sitting for awhile without being used. The red standby light is on when its plugged in but the tv won't turn on. The reset seems to do nothing, unplugging and replugging does nothing, and the light just stays solid red (no blinking, green or blue light). Is there anything I can do or is it toast? Thanks for any help.

Answer this question I have this problem too

Is this a good question?

Score 2

Comments:

I have same problem. Use remote to try turn on….see green disappears and flashes in sequences of 6. My tv is a Sanyo smart tv. No buttons on back. All remove. Tv less than 3 years old. Can't afford a new one. Never will I buy a Sanyo anything again! Stick to LG electronics from now on ?

by

TV not coming on even after cable reboot

by

@susanbaker55

What is the model number of the TV?

Is the TV's red standby light on or off?

If not on have you checked that the wall outlet is working OK?

If on, have you tried using the TV control buttons instead of the remote?

What have you tried?

by

Add a comment

4 Answers

Hi Nicole,

If you press the power button on the TV itself, does the red light blink or have any changes? Try unplugging it from the electrical outlet, and while its unplugged hold down the power button on the TV for 45-60 seconds, then releasing and plugging back in. Once plugged in does the red light blink, or come on solid?

Was this answer helpful?

Score 0

Comments:

It's solid. I tried unplugging and holding the power button, holding the menu and vol - buttons and then all three. Tried different outlets. Tried using the remote to do it. The light just stays solid red and nothing else happens.

by

Yes the red light blinks and stays on l a m p

by

Yes it blinks

by

Add a comment

Hi @lilyandtwitch ,

It could either be a mainboard or eeprom problem.

Unfortunately this supplier has no mainboards in stock but has provided good advice about what to look for when searching for other suppliers of a replacement mainboard (Take heed of the Note in red on the webpage under the eeprom part).

Was this answer helpful?

Score 0

Comments:

Is there a reason that the board could've broken? Is it possible that it's dusty inside the tv since it's been sitting long without use?

by

Hi @lilyandtwitch ,

It's more likely that the eeprom has become corrupted somehow or the mainboard has manufacturing defects like poor solder connections of the components that over time emerge.

The eeprom is where the firmware that runs the TV is stored and the eeprom is mounted on the mainboard.

Also your model TV or more correctly the mainboard hasn't got a good track record for longevity.

If your mainboard sticker number matches the information in the link I provided you could contact the supplier in the link and ask if the eeprom has the firmware already loaded and then try just replacing it if you can or know someone who can (smd soldering expertise and tools required) or if your board isn't a match ask them what your best option is.

by

Ok thanks for all the help.

by

Yes l have a Sanyo TV. I have had it for 5 yrs. From what you are saying the track record on them is not good. I got up this morning and it is beeping no power.

by

Add a comment

There is a small power button behind the TV. Try switching on using that.

Was this answer helpful?

Score 0

Comments:

I don’t see a small power button behind the tv

by

@Nashie Sexton

What is the model number of your TV?

by

Add a comment

The tv turns on, but it turns right

Was this answer helpful?

Score 0

Comments:

It turns off immediately

by

Add a comment

Add your answer

Nicole will be eternally grateful.
View Statistics:

Past 24 Hours: 32

Past 7 Days: 178

Past 30 Days: 602

All Time: 12,079