Skip to main content

Fix Your Stuff

Right to Repair


The Nextbook Ares 8A is an Android tablet released March 2017.

40 Questions View all

Why does this keep going to the "battery charging" screen?

The warrenty has long expired on this old tablet, but I was still trying to figure out how to get it to work again. I’ve tried resetting and restarting, and it can get to the home screen with the basic water droplet background. I can tap on settings and go into it. I can look around for a minute or two to try and figure out the problem. But it keeps turning off and going dark. Then it lights up, showing the Nextbook logo, then the empty battery screen. Then it goes dark again. And comes back on with the “charging” battery screen. I’ve tried a firmware update, and it says there’s no firmware update needed. Most curious of all, the square (recent apps) button, and the circle (home) buttons simply show up the oval around them to say, “Yeah, you touched it.” But they do absolutely nothing. However the triangle (back) button still works fine. Any help?

Edit: Also, is there any way to completely factory reset it? I wasn’t allowed to go to the app store until I signed in with a “Google account associated with the original owner,” or whatever. Basically it asked me to sign in with one of the accounts I HAD signed in before on the device. Is there a way to reset ALL memory? I’m not worried about losing anything on the device, it’s empty anyway. I just want the thing to work, and to start over fresh with it, as if I just got it out of the box.

Edit 2: The menu you pull down from the top is also choosing not to work at random, if that can be fixed also, I would be very grateful.

Answer this question I have this problem too

Is this a good question?

Score 0
Add a comment

1 Answer

How's it going so it sounds like it could be a loose connection inside of it that could be a case of why it's shorting out on you I also had a tablet before and it would be so kind of the same thing to me as well and I plug it in and charge it but it wouldn't really charge it was just showing that it was charging and I found out that the charger that I was using wasn't strong enough for the tablet so that might be an issue as well if you guys are good at disassembling Electronics try taking it apart and as you take apart check to see if wire's are loose or if there's breakage in soldering from the board if there's solder breakage from The Wire then it's easy to solder it back together and you got to remember the pieces as you take apart where they go so they all fit back into it and that might work as well if problem still occurs I'll be happy to read more things to see if I can find out another solution for you please let me know and I'll always there to help

Was this answer helpful?

Score 0


My dad's really good at taking them apart and putting them back together, but would you know where the seam is to open the case on one of these? We tried to take the casing off for a few hours, but to no avail. I have the blue nextbook, so it LOOKS like there's a seam. But no matter what we're using we can't get it apart. Can you help us find a seam? If I had a picture, would you be able to add an indicator which seam it is we're trying to open to get the back off?


Add a comment

Add your answer

Jinyoung Kim will be eternally grateful.
View Statistics:

Past 24 Hours: 0

Past 7 Days: 0

Past 30 Days: 1

All Time: 13