Display issues - External monitor works Okay

Hi All,

I’m having a weird issue with my laptop.

If I do not have an external display plugged in I cannot use the internal display as it displays some strange multicoloured patters.

With the external display plugged in my internet screen sometimes has a yellow hue or a blue hue. I’m thinking this is an issue with the built in display however I’m not sure and don’t want to drop £300 on one for it to not work.

I have done a screen shot when the screen is blue and also when the screen is a colour pattern and the screen shot comes out fine, making me think the GPU is okay?

I have tried a new LVDS cable however that didn’t change anything, one thing to not that a couple of months ago the laptop had a small fall. It dented the screen on the bottom around .5cm long and is the opposite side to the LDVS cable. So WiFi cable side, nothing really went wrong with the laptop straight away however i’m not starting to think that it has something to do with it.

I have attached some photos of what the laptop does.

Any help is greatly appreciated.

Many thanks

Jon.

Block Image

Block Image

Block Image

Block Image

Answer this question I have this problem too

Is this a good question?

Score 0

Comments:

I'm a bit confused here as you don't have any references per each image.

So if I understand it you have no issues with either the external or the internal monitor when the external is plugged in - Is that correct?

So when you disconnect the external the internal goes wacky! Your images remind me of the title sequence to the Matrix ;-}

Which interface is your external using?

by

Add a comment