Skip to main content

2018 model Internal part number: HE500S5U51

4 Questions View all

Have sound. But no image

Hello. Working on a Hisense 50P7 which powers on with backlight and sound. but no image of any kind (menus etc) the sound works via both tuner input and HDMI.

I have measured the power supply voltages. 12V and 18V pins all measure correct. However “STB” only measures 0.5V when off and 2.7V when on. Which seems off to me.

Have measures all backlight connections have ~47.3V on all VO pins. And 4.7-5.3V on all backlight led pins. While the backlight is dim. It appears to he consistant when veiwed in a dark room.

When powered on. The power led flashes 17 times. Not sure if that is relevent but earlier models seemes to use it for fault codes.

Have disconnected and reconnected all plugs / ribbons with no change in behaviour

Have measured the fuse on the video driver pcb and that is still intact (measures about 11.6V)

None of the capacitors loom to have a bulge. But have not yet removed and measured them.

Looking for any insights into what may be the underlying fault and where I can start.

Block Image

Block Image

Block Image

Block Image

Block Image

Block Image

Answer this question I have this problem too

Is this a good question?

Score 0
Add a comment

1 Answer

Most Helpful Answer

@rerouter “0.5V when off and 2.7V when on “ appears a bit low for it to be stby. Your symptoms are usually indicative of a bad main board or bad T-con board. Post an image showing all of your boards mounted to the chassis including the interconnect wiring.

Was this answer helpful?

Score 1

4 Comments:

Added photos for you. Rechecked. And definatly those voltages on stb

by

The center board under the metal frame is your T-con board. There will be a fuse on it, most often found right beside the connector for the ribbon cable. Check to see what voltage you get on that. Most commonly would be 12V

by

Correct. It measures 11.6V and the fuse is located below the right hand side of the top ribbon connector for anyone who might see this model in the future (green square component)

by

Ok so it gets power. If you can still see your on board menus it is most likely the t-con board. If you cannot it is the main board. BTW while your TV sound played and you had no picture, you did check the screen with a flashlight beam angled against it, to see if you can make out shapes, silhouettes etc. right?

by

Add a comment

Add your answer

Ryan Favelle will be eternally grateful.
View Statistics:

Past 24 Hours: 0

Past 7 Days: 0

Past 30 Days: 19

All Time: 339