Skip to main content

Fix Your Stuff

Right to Repair

Store

The PowerMac G5 is a desktop computer first produced in 2003 by the Apple Corporation. This guide will review the repair process of an Apple PowerMac G5 model number A1047 EMC 2061 from 2004. It was discontinued in 2006 as part of the Intel switch first to developers then consumers.

237 Questions View all

Boots from PRO 860, but fails when I update the OS.

Customer brought in a Power Mac G5 with a failed HD, and for reasons decided to upgrade to an SSD. I put an Samsung PRO 860 inside, booted from a Leopard DVD, formatted the drive, and installed Leopard. No issues, and everything works fine. I then ran software update and it downloaded two updates, 10.5.8 and (I think) iTunes. When it restarted, it couldn’t find a bootable volume any more.

If I boot from the Leopard DVD it sees the volume as having 10.5.8 installed on it, and Startup Disk sees it as a viable boot volume. Holding OPTION at startup shows no bootable volumes (assuming the Leopard DVD has been removed).

I thought it might have been a bad install so I tried again with the same results: Under 10.5 it works fine, but after Software Update it breaks.

Some Googling around revealed that disabling TRIM may solve the issue so I removed the drive, put it in a PC, used Samsung Magician to disable TRIM (reformatting it in the process), put it back in the Mac, and tried again with the same results.

I tried it in both drive bays, same results.

Why can’t I boot this drive?

UPDATE: If I install 10.5, then update to 10.5.8, on a traditional spinning HD, then clone the resulting system to the SSD, the SSD boots and works normally. So it’s something to do with the update process itself that’s causing the issue.

Answer this question I have this problem too

Is this a good question?

Score 0
Add a comment

1 Answer

Most Helpful Answer

Sounds like you didn’t format the drive to the correct low level format. The G series use an older format type than what the Intel systems use (GUID/HFS+).

You also need a SSD which supports SATA I (1.5 Gb/s) unless the spec sheet calls it out the drive won’t work! Luckily the Samsung 860 EVO is one of the few that should work.

Apple never validated SSD’s with the older OX-X’s, El Capitan is the first release Apple offered TRIM support for 3rd party drives which doesn’t help you.

You’ll need Cindori’s Trim Enabler for the OS-X Leopard. I’m not sure if they offer a compatible version for the G series version OS’s.

Was this answer helpful?

Score 1

Comments:

If I formatted the drive wrong, I wouldn't have been able to boot into 10.5. But I can. Unless you're suggesting the drive format changed during the 10.5.8 update process?

The PRO 860 does support SATA I.

I've disabled TRIM on the PRO 860 so that's not an issue. (Trim Enabler is Intel-only so that wouldn't help anyway.)

by

Add a comment

Add your answer

Steve Godun will be eternally grateful.
View Statistics:

Past 24 Hours: 0

Past 7 Days: 0

Past 30 Days: 1

All Time: 37