No Sound From Internal Laptop Speakers

I have no sound through the speakers of my 1.83 GHz Core Duo MacBook Pro. When I try to turn up the volume, there is a circle with a line through it. When I go to system pref under "sound" it's like the opt to change the volume isnt available. I do however get sound through the headphone jack.

Can anyone help me?

Thanks,

Paul

Answered! View the answer I have this problem too

Is this a good question?

Score 0
Add a comment

2 Answers

Chosen Solution

Hi! This may not help, but I'd try resetting the PMU -- with the power off and the computer connected to AC, hold the power button in for about 10 seconds. You should hear a tone (which means sound is working), and then see the sleep light flicker. I've found that sometimes this can cause the sound to become "un-stuck" in cases like yours.

If you do hear a tone during the PMU reset, but the OS still is not seeing the sound hardware, that's an indication that it may be a software problem, and I would recommend wiping your hard drive and reinstalling the OS in order to determine if that is the case.

You can also try resetting the PRAM.

Was this answer helpful?

Score 1
Add a comment

Hey! I ran into this problem late last year with a Black MacBook. These models were manufactured around the same time, so I wouldn't be surprised if something like this works.

Take a paperclip (or something similar), unbend it, and fish around in the headphone jack (carefully!) until you "close" the optical sensor. (I don't know if there is better term for this). You might also try plugging and unplugging a set of headphones a few times, it could have a similar effect.

Worked like a charm on the black unit.

Was this answer helpful?

Score 1
Add a comment

Add your answer

Paul Smith will be eternally grateful.
View Statistics:

Past 24 Hours: 0

Past 7 Days: 3

Past 30 Days: 5

All Time: 2,483