Water damaged s6 edge+ drawing 0.03A when prompt to boot

I am getting into microsoldering recently so go easy on my guys, I have been repairing and into phones since Motorola V3 days so been around for a while and im ok at soldering.

Anyway this is a phone I damaged 2 years ago before I was into micro soldering. I spilled coffee on it while flat face up on table. Cofee covered the screen and I turned it off and wiped everything down, dried it with har dryer etc. It would turn on but random shut down etc. I took out the motherboard did the usual iso alcohol bath, no visual corrosion or water damage signs. Still random power off behaviour. What I did next is use a heatgun on about 360 degrees and went around the whole board thinking .. not sure what I was thinking but this killed it totally and its been in a draw for 2 years.

Now as a learning prob I got it out and after watching some videos I tried to shadow the process.

Checked all the components on the vbat line in diode mode, none of the components showed continuity on both ends to the ground . Working off xwz tools these 8 components are on the vbat line c7105 ta7000 d7000 c7023 r7030 c7109 r5037 r7020 the last being a pin under the pmic (havent removed it)

soldered a cable to the vbat connector and attached to positive on a dcps clipped the ground to the sim slot. When shorting the power button dcps shows a draw of 0.03A when set at 3,8~4V when let go of the button pins the draw drops to 0.

Tried the same procedure with the 2 bigger components on the line which are ta7000 r7020 soldering the postive cable to their positive ends, exacly the same results 0.03A draw and when let button go back to 0.

So according to my novice research I don’t think vbat line is shorted, had a look under the microscope and cant visually identify any damage.

Could it be the pmic that is the culprit here?

Any tips and advice welcome

Thanx in advance

Answer this question I have this problem too

Is this a good question?

Score 0
Add a comment