Skip to main content

Kohler makes the gas powered engines for many different riding mowers & garden tractors both for home owners and professionals.

7 Questions View all

Why are blades not engaging after replacing PTO switch?

Belt appears to be loose…but no response when pto switch is on. Know that blades will not engage if belt is off…but shouldn't there be some response or noise when switch is on?

Answered! View the answer I have this problem too

Is this a good question?

Score 0
Add a comment

Skip the upgrade.

Take $10 off $50 with
SKIPANDSAVE10

Save Now

Skip the upgrade.

Take $10 off $50 with
SKIPANDSAVE10

Save Now

1 Answer

Chosen Solution

You may have a wiring issue, such as a loose connection or a damaged or broken wire. Take some time to trace and inspect your wiring through each safety switch and/or other connection, and to ensure connections are sound, throughout. this is relatively simple and there is no expense except your time, and it’s possible you might find and easily correct the problem.

Don’t know what kind of mower you have, but most use a couple of switches to ensure safety before operating the mower. For instance, you have to be on the seat, and the clutch has to be depressed, and the deck has to be in the up position, etc., before the mower can be started. And, the mowing deck itself must be lowered before you can start the mowing action. Considering you said a belt must be in place, as well, in order for the PTO to engage, there must be some type of switch used there, also.

Generally, most Safety switches are tested with a multi-meter for continuity to ensure they’re working.

Hope this helps. If not, add more details about your mower (mfr, model no., etc) and maybe we can come up with something more specific.

Was this answer helpful?

Score 1
Add a comment

Add your answer

Rajus Vincent will be eternally grateful.
View Statistics:

Past 24 Hours: 0

Past 7 Days: 1

Past 30 Days: 5

All Time: 23