Skip to main content

W124 is the Mercedes-Benz internal chassis-designation for the 1984 to 1995/96 version of the Mercedes-Benz E-Class, as well as the first generation to be officially referred to as E-Class. The W124 models replaced the W123 models after 1984 and were succeeded by the W210 E-Class after 1995. In North America, the W124 was sold for the 1985 through 1996 model years.

1 Questions View all

Why does my engine hunt at idle?

I have a 1993 190E (2.3 4 cyl.) Regardless of outside conditions and how I’ve driven the car, when I stop, the idle fails to come down below 1800 to 2300 RPM and it hunts up and down between 1800 and 2300 RPM. f I take my foot off the brake, it accelerates and gets to whatever speed 1800 and 2300 RPM will allow. A few minutes later, everything goes back to normal RPM and all is well for a few days. Then, for no apparent reason, it does it again. M-B dealership has been unable to find the fault. I.we have tested all pneumatic hoses that have to do with idle, they replaced some temperature sensors and I’ve replaced the throttle body. I have a very good relationship with my dealership - have bought seven M-B cars there and I trust them. I wanted to buy another 190E from a private seller and that car drove normally except at the very end of the test drive. As I pulled into the seller’s driveway, that car did the same thing. The seller said that it had never done that before. I didn’t buy the car. But I’m wondering if anyone else has experienced this and has anyone diagnosed the problem successfully. Please don’t come back with lame “does the car have enough gas in the tank” types of suggestions. I am an aircraft mechanic and not a complete idiot around mechanical things. But this phenomenon baffles me as it does a dealership full of M-B mechanics. Thanks in advance for any help that you might be able to provide.

Additional information:

The relay pack ( almost directly below the heater/AC fan in the cabin) for the daytime running lights had been removed as one M-B Tech traced a wire that was in the circuit that sensed idle RPM and went through that relay pack, presumably to turn the daytime running light s on. That made no difference to the problem and the relay pack was reinstalled. I subsequently removed it (it’s really simple) and turn the headlights on and off manually

All temperature sensor have been replaced and the air flow sensor was replaced at the same time as the throttle body.

There are no faults showing when the ECM (Engine Control Module) is interrogated. An ECM from a junk yard was substtuted, but the problem did not go away. (The chances of another ECM having the exact same problem are somewhat remote) I’m back to running with the original ECM

Answer this question I have this problem too

Is this a good question?

Score 1
Add a comment

MacBook Battery Fix Kits

Starting at $69.99

Buy Now

MacBook Battery Fix Kits

Starting at $69.99

Buy Now

1 Answer

Have you checked the Idle Control Valve?

Also check vacuum hoses for leaks.

Was this answer helpful?

Score 0

Comments:

Yes, the dealership did - it was one of the first things they checked - and they checked it several times. It would also have left a fault code on the ECM if it was faulty. At one point we were “lucky” enough that the engine was hooked up to the dealer’s analyser while the fault was occurring. It showed nothing except for a higher than normal engine/idle speed. It was as if someone was inside the car blipping the accelerator. We suspected a faulty ground in the accelerator to ECM circuit causing the ECM to sense a varying ground resistance which would make it think that someone was moving the accelerator pedal, but the grounds, as well as all of the other wiring checked out

by

Add a comment

Add your answer

Thomas Daniel will be eternally grateful.
View Statistics:

Past 24 Hours: 1

Past 7 Days: 7

Past 30 Days: 49

All Time: 49