13" aluminum unibody, 2.0 or 2.4 GHz Core 2 Duo processor.

576 Questions View all

LCD has no Backlight, not even on replacement LCD

Hi,

I have a Unibody MacBook (A1278). At the end of the last year, there was a white stripe on the LCD, Backlight still worked.

Sometimes, if I moved the lid (or pressed on the lower glass border) the Stripe was away and anything worked normal .. But last month it has gone worse. The stripe had become nearly the half of the screen.

I bought a new LCD Panel (Samsung LTN133AT09) and replaced the old one. But now the Backlight doesn't work. (Not even on the old one)

> If it would be the graphics card (or the logic board), that lid moving and pressing on the lower glass border couldn't work, right? (VGA-Out works)

> Could it be the LVDS cable? or

> is it the LCD inverter? But someone told me, that the inverter board is attached on the LCD itself. So I already replaced it together with the LCD Panel, right?

Please help me .. It slowly gets expensive for me as a poor college student :/

Answer this question I have this problem too

Is this a good question?

Score 1

Comments:

What happens when you hook it up to an external monitor?

by

No problems with external monitors ..

by

Add a comment

2 Answers

Most Helpful Answer

as this model uses an LED display and not a traditional LCD, there is no seperate inverter. i would start by replacing hte LVDS cable and also ensuring that all connectors are securely connected.

Verify that the rest of the LCD is working correctly first by shinning a light into it, you should see your picture faintly. If you do not see anything, then you are having signal issues, which the cheapest way to check is first with the LVDS cable. If there is no change, then try a different LCD panel.

As it works correctly with an external monitor, it is not the logic board, unless it's the LVDS connector on the logic board, which is highly unlikely.

Was this answer helpful?

Score 2

Comments:

Thanks Pierrej, yeah, I can see a picture .. its only the backlight whats missing ..

I just ordered a new one and will give it a try.

by

I replaced the LED panel and the LVDS Cable ... Still no Backlight :( So what could it be? I have no idea :/

by

Add a comment

There is a small cushion glued to the LVDS connector on the logicboard. Sometimes this puts to much pressure on the connector, causing issues. Try to run the computer with the bottom lid off or remove the cushion. Hope that helps.

Was this answer helpful?

Score 0
Add a comment

Add your answer

eltomato will be eternally grateful.
View Statistics:

Past 24 Hours: 0

Past 7 Days: 0

Past 30 Days: 2

All Time: 2,010