Model A1288 / 8, 16, or 32 GB capacity

581 Questions View all

new battery wont take a charge and iPod wont power up

I replaced battery because my daughter gave me her ipod touch 2nd gen to fix when I recieved it all it did when plug in to wall or computer was show a red bar in the battery and a lighting bolt underneaththe battery. I removed the old battery and replaced with one I bought from ifixit. I plug the cable into the usb and then I got the same red bar in the battery and a lighting bolt in the window then after about 3 minutes I get an apple in the screen but nothing else I have tried to reset I even removed the battery and replaced it again with the same results please any suggestions

Answered! View the answer I have this problem too

Is this a good question?

Score 0
Add a comment
Deck the Halls
With tools and Fix Kits

2 Answers

Chosen Solution

pellis1309, make sure that your dock connector is clean of debris i.e. lint and that there is no corrosion. Also check the pins and make sure that there is no bent ones. Charge the battery on a wall charger first and see if that works better. it does provide more amperage than your USB port. It is possible that it is stuck in a recover loop and I usually use iReb for those. You can download it from here. Give it a try and see if it kicks it out of recovery. Of course make sure that you double checked, or in your case, triple checked your work. You should also try a new USB cable, just in case... Good Luck

Was this answer helpful?

Score 2
Add a comment

The same problem seems to be happening to my Ipod and I don't know if I can fix it and recover the data or not. I understand from pellis1309 that changing the battery had not worked so wonder if this is some kind of fault that Ipod 2nd Gen has.

I have tried charging the ipod on a wall charger and on USB but nothing happens. Occasionally when I try to restart the device the same battery sign comes up with a red line on the left and a lighting bolt underneath it. Please advise.

Many thanks.

A

Was this answer helpful?

Score 0

Comments:

Have you checked your dock port for dirt/debris/bent pins as oldturkey03 suggests? They tend to gather lots of gunk from pockets etc in there and it stops the pins making contact for charging. Use a tooth pick to see if you can remove any visible dirt. Did you replace the battery?

by

Add a comment

Add your answer

pellis1309 will be eternally grateful.
View Statistics:

Past 24 Hours: 0

Past 7 Days: 0

Past 30 Days: 0

All Time: 724