Skip to main content

Fix Your Stuff

Right to Repair

Store

The Smart Oven® with Element IQ® is a trustworthy tool for the cook who wants a countertop oven that roasts succulent meat, broils, bake pizza, reheas leftovers and toasts evenly. Convection setting reduces cooking time by up to 30%. Model: BOV800XL

10 Questions View all

Thermal fuse or other component?

Display lights up and accepts function settings but none of the elements come on so no heat. I was going to replace the thermal fuse but when I opened the back/side of the housing, I noticed a blackened patch on the board (see photo).

Could use some help diagnosing the problem. Thanks!

Block Image

Block Image

Answered! View the answer I have this problem too

Is this a good question?

Score 2

Comments:

Did you end up finding the fix to this issue?

by

Add a comment

SKIP THE UPGRADE

Save by fixing with an all-in-one kit.

Shop iPhone Fix Kits

SKIP THE UPGRADE

Save by fixing with an all-in-one kit.

Shop iPhone Fix Kits

2 Answers

Chosen Solution

My guess is that the white sleeve covers a push-on spade connector which is loose, causing it to get hot. If you pull it off, clean it up and squeeze it slightly with a pair of pliers, you should be able to make it fit much more tightly and make a better contact.

Was this answer helpful?

Score 2

Comments:

Thanks Philip. I lifted the sleeve and there is a push-on spade that is loose. There also appears to be loose “crusty” material under the board beneath the connection. I tried to pull the spade up and off but it is resisting. Should I just apply more pressure and pull harder?

by

I would be careful about pulling it to much as we don't want the connector to break.

by

Add a comment

For me, my 10 years old Bov800xl stopped heating all of a sudden, thought it was the end…all the panel fonctions were fine but no heat and no sound, …unscrewed the thousands screws to remove cap, after a day, I succeeded, …

ended up trying a number of things, till I had nothing to do left but to remove the mother board, like you can see on the picture above…and found that the fan connector, where the fan wire attach to the mother board, was a bit loose

so unplug fan, and replug tigher.

this simple fan connetion was my problem.

The isolation of my old Breville must be the responsible, deteriorating with time, heating and cooling those connectors every use , *and It has been use, at least twice a day for 10 years…

good luck to you all!

Was this answer helpful?

Score 0
Add a comment

Add your answer

Kevin C will be eternally grateful.
View Statistics:

Past 24 Hours: 6

Past 7 Days: 65

Past 30 Days: 318

All Time: 3,819