Complete repair manual for the PSP Go, including battery upgrade and display repair instructions.

44 Questions View all

Loss of audio Output From Units speakers.


I have my psp go doing an odd thing.

It powers on fine and all functions are correct - save one. Audio.

Initially i susected that the device was assuming thati had headphones in - but when headphones are inserted the volume changes ion screen to the volume i had set last for headphones and audio is outputted through the headphones.

I then suspected that there may be dirt in the dock and thourghly cleaned the dock. Still no sound from speakers.

I then stripped PSP down as per your guides and looked at the speakers themselves - visually nothing "seems" wrong.

What areas should i be focussing on to rectify this fault?

Is it possible the speakers have blown after a heavy bout of dance/trance bass?

If so where can i obtain replacement parts?

Thanks in advance



Reading other psp go problems i found this fuse diagram.

I dont speak/read russian and dont know if these fuses are relevant.

Anyone care to share a translation?

Answered! View the answer I have this problem too

Is this a good question?

Score 1
Add a comment

5 Answers

Chosen Solution


It is a piddly little fuse on the right side of the motherboard as you remove rear case.

It is marked with the letter L.

My fix is more of a bodge tbh.

I desoldered the fuse and used a bit of thin wire to make the circuit.

to make the fix permanent i need a new fuse lol.

Anyways hope this helps someone out in the future

Was this answer helpful?

Score 1


Great job, now all you have left to do is to accept your own answer. That way we will know that this works. Again, great job.

by oldturkey03

Fuses blow to protect the rest of the system. By bypassing it you risk serious damage

by mayer

Add a comment

Im having the same problem here. No sounds through speakers. Earphones works perfectly.

I didnt silde the fuse of but I tried to connect 2 sides of a fuse with a wire but when they were connected the psp didn't boot up. when I remove the wire everything works again but still no sounds

is there anyway I can check if its really a fuse problem or not ? I'm just a noob so please help xD

I know this is an old topic but please help me !

Thank in advance :)

Was this answer helpful?

Score 0
Add a comment

I had the similar problem and by repairing the fuse problem solved.

Thanks Coxy.

Was this answer helpful?

Score 0
Add a comment

i replaced the fuse. now my start/select button don't work. You think related ?

Was this answer helpful?

Score 0
Add a comment

^ you might have not have done it correctly.

Make sure you didn't leave any residue around the components. It can cause faulty things to happen.

Was this answer helpful?

Score 0
Add a comment

Add your answer

Coxy will be eternally grateful.

View Statistics:

Past 24 Hours: 0

Past 7 Days: 19

Past 30 Days: 62

All Time: 5,667